Announcement

Collapse
No announcement yet.

Error with preg_replace() while upgrading from vb4 to vb 5.0.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error with preg_replace() while upgrading from vb4 to vb 5.0.5

    Hello everyone, I'm upgrading from 4.2.2 to 5.0.5 and I faced an error that stoped the proccess (see the attached image). any ideas about how to deal with that will be greatly appreciated.
    The database is huge (1.2 million posts , 200+ thousand users), but i'm not sure if that may cause such an error.
    P.S. the forum is in Arabic language, and there is no live version for now. thanks Click image for larger version

Name:	3.jpg
Views:	34
Size:	64.8 KB
ID:	4020098
    Attached Files
    Last edited by samerss; Fri 14 Feb '14, 6:38am.

  • #2
    Hello samerss,

    Which version of PHP do you happen to be running? Just run phpinfo(); on a new page on your server.

    Kindest Regards,
    Lane

    Comment


    • #3
      What version of PHP/MySQL on the server?

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #4
        php version 5.3.14
        mysql version 5.5.24


        Comment


        • #5
          When you look at your phpinfo() output, what is the version of the pcre library?

          May try upgrading PHP to a fresh 5.4.25 installation.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            PCRE Library Version 7.8 2008-09-05
            thanks for the reply Wayne. I'll restore the old db and start the process over again (machines change their mind sometimes). If I faced the same error, then I'll upgrade my php then start again.

            Comment


            • #7
              One more question please. If I just install vb5 as a new forum, and then transfer all the data from the old db (vb version 4.2.2) to the new db. is that possible? and is there any script to transfer the data automatically?
              for now, I'll upgrade php version as you recommended, but i'm just thinking about any other options in case I couldn't complete the upgrading process.
              thanks again.

              Comment

              Related Topics

              Collapse

              Working...
              X