Announcement

Collapse
No announcement yet.

Require moderator validation before new threads are displayed the problem ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Require moderator validation before new threads are displayed the problem ?

    I found In the Forum Permissions option Follow Channel Moderation Rules (If no, posts are always placed into moderation queue) selected from a no, what I need is how to achieve Require moderator validation before new threads are displayed?
    [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

  • #2
    Originally posted by anwar513 View Post
    what I need is how to achieve Require moderator validation before new threads are displayed?
    The option you describe does exactly what you want.
    1. Create a new forum (channel) and select "No" for this option for a certain usergroup (e.g. "registered users").
    2. Result: All topics of this usergroup, that are created in this channel, need admin/moderator approval before they show up.

    Comment


    • anwar513
      anwar513 commented
      Editing a comment
      I'm sorry my English is not very good, I need detailed steps?

  • #3
    Hi there,

    I used the admin details for your site that you PM'ed me. As expected, everything works the way you want it. Here is what I did:
    • I created a new forum ("Moderated Forum") under "AdminCP > Channel Management > Channel Manager".
    • I went to "AdminCP > Channel Management > Channel Permissions" and clicked on "Edit" next to "Registered Users" (under the new "Moderated Forum"). This allowes to edit usergroup-based permissions for just this single forum. There I set "Follow Channel Moderation Rules" to "No".
    • I created a new user ("registered user"), which belongs to the "registered users" usergroup. (It has the same password like the admin account you PM'ed me.)

    Now you can go back to the frontend.
    • Log in as the "registered user".
    • Go to the "Moderated Forum" and create a new topic.

    As you can see, the topic does not show up in the forum. If you log out now and log in again as an administrator (or moderator), you can see that this topic was placed in the moderator queue. It needs to be approved before it shows up.

    I guess this is what you wanted. You can do the same now with other forums on your site.

    Comment


    • #4
      Thank you very much tutorial
      [ATTACH=CONFIG]temp_64550_1413220742153_785[/ATTACH]

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X