Announcement

Collapse
No announcement yet.

Cannot Upload Images

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Upload Images

    Registered Users reported this. Administrator (myself) tested and these are the results:

    From a post at the bottom of a thread, I chose the Advanced Editor. It opened the WYSIWYG. I clicked on the image button. Clicked on the Upload tab. Uploaded an image by clicking the "Send it to the Server" button. It put me back in the editing window. Added some text and hit Post and got the following error:

    "You are not authorized to make this post."

    This has never been an issue since upgrading to 5.0.5.

    I checked all permissions and can find nothing out of the ordinary.

    Time to open a ticket?

  • #2
    FYI, I used Diagnostics for File Upload and got this:
    Pertinent PHP Settings
    file_uploads: On
    open_basedir: None
    safe_mode: Off
    upload_tmp_dir: None
    upload_max_filesize: 10.00 MB
    Help
    Results
    No errors occurred while opening the uploaded file for reading.

    Comment


    • #3
      What do you have set for AdminCP > Settings > Options > Message Posting and Editing Options > Topic Comment Posting? Set that to Yes, then Clear System Cache, and see if you may attach an image.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help

      Comment


      • #4
        Reviving this. I do not want to allow Comments on posts as this is a horrible "feature" and makes for confusing conversation.

        After upgrading to 5.1.0, I now can upload attachments but get the error "You are not authorized to make this post". I then try to post it again and it tells me that I am making a duplicate post. I look at the thread and the image is there.

        I guess this is progress?

        Comment


        • #5
          Are you moderating posts?

          Comment


          • #6
            Nope.

            Comment


            • #7
              So... I don't want comments on my posts. I do not moderate posts. There is another thread here where a user is stating that they also are getting the message "You are not authorized to make this post"

              Ticket time?

              Comment


              • #8
                Bump. I can do this every day if need be.

                I KNOW you guys are willing to help. It must have been break time?

                Comment


                • #9
                  Can users comment on topics? Both in usergroup, and the vBulletin settings?

                  Comment


                  • #10
                    Yes. Turns out... when I uploaded an image as an administrator, I could see it when I posted it. Still logged in... the images are now gone.

                    Here is the link (I think it is a public board...):
                    http://www.nwdiscgolfnews.com/forum/...e-status/page3

                    Comment


                    • #11
                      Bump

                      Comment


                      • #12
                        I am getting the same issue, with vBulletin™ v5.1.1.

                        1.) Logged in using an Admin account and then tried to upload a screenshot from my iPhone.

                        2.) Clicked Upload Attachments --> Select a photo from my camera roll --> Done --> Click "Post Reply"
                        I got an error message "Edit Conversation: You are not authorized to create this post".

                        3.) Surprised, I clicked "Post Reply" again, this time, I got another error message "Edit Conversation: This post is a duplicate of a post that you have posted in the last five minutes"

                        4.) Then all sorts of weird things followed: sometimes, my reply with photo showed up despite the error message and sometimes, only reply showed up but no photo.

                        Any update on resolution?
                        Last edited by Fred Li; Wed 18th Jun '14, 6:39am.

                        Comment


                        • #13
                          Hi, All, I found a solution from the following post:

                          http://www.vbulletin.com/forum/forum...-uplading-file


                          Excerpt of the solution that worked for me:

                          "Ok, this is indeed a bug in vBulletin 5.1.0. I found a hint at how to work around it in another thread. Let me fully describe it here.

                          This issue arises if the channel permissions for a particular usergroup have 'Can Comment' set to 'No', OR if in AdminCP -- Settings -- Options -- Message Posting and Editing Options, 'Topic Comment Posting' is set to 'No'.

                          You have to set 'Can Comment' for all usergroups for all channels to 'Yes', AND you have to turn 'Topic Comment Posting' on in the Message Posting and Editing Options."

                          Comment

                          Related Topics

                          Collapse

                          Working...
                          X