Announcement

Collapse
No announcement yet.

Fatal error: The requested language does not exist

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • chris_654
    replied
    So I accessed my forum today, without making any changes, and everything is functional again. I literally did nothing between the time of my last post and right now, so I'm not sure what's going on. It's working again, which is nice, but I'm still a little concerned that maybe I had a security breach? Is there anything I can do to see what happened/prevent it from happening again?

    And thank you so much for the tips Omeka and Zachery, I really do appreciate the help.

    Leave a comment:


  • Zachery
    replied
    Something, or someone did something to the database to kill your default language, this is not normal. If you're unable to get tools.php to restore it, please let us know and we can escalate a ticket for you and work on fixing it.

    Leave a comment:


  • Omeka
    replied
    With vBulletin version 5, the file tools.php, you would enter the folder /core/install. I see that thou hast put in / admincp/tools.php.

    Leave a comment:


  • chris_654
    replied
    Omeka, if I attempt to run tools.php, I get the following error:

    "Fatal error: The requested language does not exist, reset via tools.php. in /homepages/3/d166321347/htdocs/cookstoves.net/forum/core/vb/session.php on line 705"

    The only changes I've made as an admin were cosmetic (backgrounds, etc). How would I reload the default language?

    Leave a comment:


  • Omeka
    replied
    Have you run tools.php? Are you sure you do not have some admin made ​​some changes? Reload the default language and run the items described in the errors.

    Leave a comment:


  • chris_654
    started a topic Fatal error: The requested language does not exist

    Fatal error: The requested language does not exist

    vBulletin version: vBulletin 5 Connect
    PHP version: 5.4
    MySQL Version: MySQL5
    Add-ons: None installed.
    Browser: Firefox, Chrome (both up to date)

    Hello,

    Today I received the following error message when attempting to access my forum:

    "Fatal error: The requested language does not exist, reset via tools.php. in /homepages/3/d166321347/htdocs/cookstoves.net/forum/core/vb/session.php on line 705"

    If I attempt to access admin controls at forum/core/admincp, I get this message:

    "vBulletin datastore error caused by one or more of the following:

    1. You may have uploaded vBulletin files without also running the vBulletin upgrade script. If you have not run the upgrade script, do so now.
    2. The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.

    Fatal error: vBulletin datastore cache incomplete or corrupt in [path]/includes/init.php on line 89"


    I have also attempted to run Rebuild Bitfields after uploading tools.php to core/admincp, but when I try to run it, I get this message:

    "Warning: require_once(./install/includes/class_upgrade.php): failed to open stream: No such file or directory in /homepages/3/d166321347/htdocs/cookstoves.net/forum/core/admincp/tools.php on line 45

    Fatal error: require_once(): Failed opening required './install/includes/class_upgrade.php' (include_path='.:/usr/lib/php6') in /homepages/3/d166321347/htdocs/cookstoves.net/forum/core/admincp/tools.php on line 45"


    ...I'm not sure what's going on. I haven't made any changes since installing the software a few weeks ago, nor have I added any hacks or mods. It was working fine yesterday then suddenly today, nothing works. This site hasn't launched yet, so there are only a handful of members and I'm the only one with admin access. I would appreciate any help or advice you can offer.

    Thanks.

    P.S. Since writing this post, all error messages have turned into this, no matter where I go:
    Fatal error: The requested language does not exist, reset via tools.php. in /homepages/3/d166321347/htdocs/cookstoves.net/forum/core/vb/session.php on line 705

Related Topics

Collapse

Working...
X