Announcement

Collapse
No announcement yet.

Users cannot register and I cannot use a login check via php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DaSpamer
    replied
    Well I've did these steps,
    We changed server settings, re-downloaded vb5 and installed again.
    changed database again.
    Debugged and still no help.

    Debug Information
    Page ID: 6
    Parent ID: 4
    Page Template ID: 6
    Route ID: 13
    Page Type: custom
    Screen Layout ID: 1
    Screen Layout Template: screenlayout_1
    Channel ID:
    Node ID:
    Database Asserts: 0
    AJAX Requests: 3
    Facebook Active: No (Not enabled or no appid & secret set)
    Style ID: 18
    Templates: 14
    preheader (parent)
    screenlayout_1 (parent)
    |----header
    |----|----ad_header
    |----|----ad_header2
    |----|----search_popup
    |----|----notices
    |----widget_announcement
    |----|----module_title
    |----widget_pagetitle
    |----widget_register
    |----|----humanverify
    |----footer
    |----|----debug_info
    ajax requests
    /registration/checkusername
    /registration/checkusername
    /registration/registration

    Leave a comment:


  • Wayne Luke
    replied
    1. Put your site in debug mode.
    2. Edit /config.php
    3. Change the line: $config['debug'] = false;
    4. It should be $config['debug'] = true;
    5. Go to /auth/login on your site and try to login.
    6. What is the error shown on the screen?

    Very little 4.X code will do anything with 5.X.

    Leave a comment:


  • Users cannot register and I cannot use a login check via php

    Hey,
    Today I've upgraded my vbulletin 4.2.1 to vbulletin 5.
    I really liked what It has and design.

    Now I'm facing problem with registrations I get this error
    Sorry, but the server is not responding properly to information requests. This may be a momentary problem. If you continue to receive this message and the site is otherwise functioning, please contact the site administrator.
    I've checked the error log
    And these are the 2 errors that are popping up (the first error, is shown hundreds over hundreds..)
    [21-Oct-2013 19:20:41 Europe/Berlin] PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/flashack/public_html/core/vb/string.php on line 750
    [21-Oct-2013 19:20:41 Europe/Berlin] PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/flashack/public_html/includes/vb5/frontend/controller/ajax.php on line 27
    I'm really not a web developer, But I used to check user login by doing this.
    PHP Code:
    <?
        
    require_once('global.php');
        if(isset(
    $_POST['username']) && ($_POST['password']) && ($_POST['run']))
            
    $username filter_var($_POST['username'], FILTER_SANITIZE_STRING);
            
    $password filter_var($_POST['password'], FILTER_SANITIZE_STRING);
            
    $user $vbulletin->db->query_first("SELECT * FROM " TABLE_PREFIX "user WHERE username ='".$username."'");
            
    $pass $user[password];
            
    $vb_hash md5($password $user[salt]); //I'm sending password after doing md5 locally.
            
    if ($vb_hash==$pass)
            {
                
    // Do my stuff
            
    }
    ?>
    And now it's don't work, so I noticed the the global function is found in the core folder so changed to this
    PHP Code:
    <?
        
    require_once('core/global.php');
        if(isset(
    $_POST['username']) && ($_POST['password']) && ($_POST['run']))
            
    $username filter_var($_POST['username'], FILTER_SANITIZE_STRING);
            
    $password filter_var($_POST['password'], FILTER_SANITIZE_STRING);
            
    $user $vbulletin->db->query_first("SELECT * FROM " TABLE_PREFIX "user WHERE username ='".$username."'");
            
    $pass $user[password];
            
    $vb_hash md5($password $user[salt]); //I'm sending password after doing md5 locally.
            
    if ($vb_hash==$pass)
            {
                
    // Do my stuff
            
    }
    ?>
    But still doesn't work.

    Here's my hosting information
    Apache version 2.2.25
    PHP version 5.5.3
    MySQL version 5.5.32-cll

    Is there any specific reason?
    I couldn't find any solution, I only found this thread
    http://www.vbulletin.com/forum/forum...l-server-error

    Which still didn't help much.


    Have you guys tested vBulletin 5 on PHP 5.5.3?
    I mean I follow the install instruction page (which says PHP 5.4 or greater), and based the thread above, users with php 5.3 are facing problems too.

Related Topics

Collapse

Working...
X