Announcement

Collapse
No announcement yet.

Invalid Page URL Page 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Glenn Vergara
    replied
    That's what I thought. Support should be able to help you fix this.

    Leave a comment:


  • claystation
    replied
    This was my problem
    Check the regex in the route_new table for that forum channel. It should have /page in it. If not, then there was a missing upgrade step that should have updated it.

    Leave a comment:


  • Glenn Vergara
    replied
    Originally posted by Mark.B View Post
    I don't currently have any forums that I created myself that run to two pages, however I have set the RSS poster to post to one of them for a bit so we can achieve this and see if it works.
    You do. The default tab for the forum page is the Topic tab, so the pagination for it is actually for the topics. So this:

    http://www.talknewsuk.com/forum/forum/main-category/main-forum/page2

    is the same as:

    http://www.talknewsuk.com/forum/foru...?tab=topic-tab

    Leave a comment:


  • Glenn Vergara
    replied
    Check the regex in the route_new table for that forum channel. It should have /page in it. If not, then there was a missing upgrade step that should have updated it.

    Leave a comment:


  • Mark.B
    replied
    Ah...doesn't work there either.
    http://www.talknewsuk.com/forum/forum/chatterbox/page2

    I don't know why it's doing that then.

    Leave a comment:


  • Mark.B
    replied
    In my case I'm fairly sure it's related to the fact that the first category was renamed.

    I don't currently have any forums that I created myself that run to two pages, however I have set the RSS poster to post to one of them for a bit so we can achieve this and see if it works.

    Leave a comment:


  • Glenn Vergara
    replied
    @claystation, I don't know what's wrong with your and Mark.B's forum channel routes. I can see in other vB 5.0.3 and 5.0.4 sites that forum pagination works.

    http://www.diecastmodelaircraft.com/...ral-talk/page2 (5.0.4)
    http://www.nifootball.co.uk/forum/fo...d-events/page2 (5.0.4)
    http://www.minutesmatterstudio.com/f...exchange/page2 (5.0.3)
    http://forumburgas.com/forum/-aa/-f-/page2 (5.0.3)

    Leave a comment:


  • Glenn Vergara
    replied
    There must be a missing upgrade step(s) that updates the forum channel route regex in the route_new table to allow /page[0-9]+ in the route. That was added in 5.0.3.

    Even Mark.B's vB5 site has the same problem.

    http://www.talknewsuk.com/forum/foru...in-forum/page2

    I remember vbulletin.com had the same problem when this site was updated to 5.0.3.

    Leave a comment:


  • claystation
    started a topic Invalid Page URL Page 2

    Invalid Page URL Page 2

    I am running 5.04 and am getting an "Invalid Page URL" error when clicking on a link to a post on page 2 of a topic. This occurs when I click on a link under the latest activity tab or module. The exact same URL will work if its accessed by clicking on the page 2 button at the bottom 1st topic page.

Related Topics

Collapse

Working...
X