Announcement

Collapse
No announcement yet.

Character issues in some parts of the forum. æøå

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • webtoad
    replied
    Bump. Still a problem here. Is it "just" a bug that needs fixing? If so, could you please forward it to jira? Because i have no idea of how to properly report bugs.

    Leave a comment:


  • webtoad
    commented on 's reply
    Man i wish my forum was just plain UTF-8 encoding. That would probably make everything ALOT easier.

  • Glenn Vergara
    replied
    Originally posted by webtoad View Post
    Please save this message with danish letters in it æøå æ æ æ ø ø ø å å å

    The above line was restored here in this topic. it should be like this:

    Please save this message with danish letters in it æøå æ æ æ ø ø ø å å å
    I was able to reproduce it here. When you load the topic page and you have an autosaved content, that content is loaded from template and not from ajax. When you view the source (not from firebug or any debugging tools), you can see this:
    HTML Code:
    <span class="h-hide ckeditor-auto-load">Please save this message with danish letters in it æøå æ æ æ ø ø ø å å å 2</span> 
    So it is not a display problem. Maybe the issue is on saving or fetching the data?

    Leave a comment:


  • webtoad
    replied
    I installed tapatalk on the forums today, and this problem also happens if a message is written from tapatalk. Doesn't autosave work with latin1?

    UPDATE: Started a thread over at the Tapatalk support. Follow it here: https://support.tapatalk.com/threads...h-chars.20101/
    Last edited by webtoad; Wed 28 Aug '13, 1:39pm.

    Leave a comment:


  • webtoad
    replied
    If i change to UTF-8 in AdminCP, then autosave works just fine. But everything else in the entire site gets messed up.

    Leave a comment:


  • Zachery
    replied
    I meant the AdminCP language setting for the language.

    Leave a comment:


  • webtoad
    replied
    Please save this message with danish letters in it æøå æ æ æ ø ø ø å å å

    The above line was restored here in this topic. it should be like this:

    Please save this message with danish letters in it æøå æ æ æ ø ø ø å å å

    Leave a comment:


  • webtoad
    commented on 's reply
    When you tell me to change character set to UTF-8, do you mean in my browser or in the language in admincp? If i change character set to UTF-8 i will break everything that contains danish letters i think?

  • Zachery
    replied
    Please try changing your character set to UTF-8, and then remove the entries from the Blank Character stripper option, in the Censorship settings.

    Leave a comment:


  • webtoad
    replied
    Here is an example. First photo is the test message. Second is what is shown after a page reload, without the message having been submitted. If i press restore the message appears as in the third photo.

    Leave a comment:


  • webtoad
    replied
    The issue with the occupation not showing character right seems to be solved with the line in the .htaccess file, Thanks!

    However the autosaving of messages does not seem to work yet. I will see if i can make an example.
    Last edited by webtoad; Sat 24 Aug '13, 2:11am.

    Leave a comment:


  • Glenn Vergara
    replied
    The charset is not specified in the HTTP Response Content-Type header for all requests. It works fine on normal requests (non-ajax) because the charset is set in the <meta> tag. But for ajax requests, there is no charset in the response.

    The response header should contain this:

    Code:
    Content-Type text/html; charset=ISO-8859-1
    Try adding this to .htaccess:

    Code:
    AddDefaultCharset ISO-8859-1

    Leave a comment:


  • webtoad
    replied
    Latin-1 (ISO-8859-1)

    Leave a comment:


  • Wayne Luke
    replied
    What character encoding are you using under Languages & Phrases -> Language Manager -> Your Language -> Edit?

    Leave a comment:


  • webtoad
    replied
    Aha. Didn't notice that. In that case my links does not show the problem. xD

    Leave a comment:

Related Topics

Collapse

Working...
X