Announcement

Collapse
No announcement yet.

upgraded - now everything is gone.Please help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgraded - now everything is gone.Please help

    Was running version 4.2.1 - if was running from in the folder FORUM\

    Uploaded the new connect files and created new folder called NEWFORUM. Copied the config.php to the core/includes folder as described.

    Did run the upgrade procedure, where everything went well and it found could see my old version 4.2.1

    Now going to the newforum, I am unable to see ANY POST of the old forum. I can not even log into admin panel with my normal user.

    What can I do ? -

  • #2
    The /core/includes/config.php file is not meant to be the same as the /config.php file - there will be a config.bak or config.new file at /core/includes - edit it with the correct settings and rename it config.php. Also the /config.php file (the one at the forum root) needs to be set with the correct settings like the core path (yourdomain.com/newforum/core)

    Also if your attachments were stored as files make sure the attachdir folder from the old forum is copied to the root of the new one

    Comment


    • #3
      Unless you meant to update your live site, you need to revert your backup, create a copy of your database and then upgrade the copy. By running the upgrade with your old config.php file, your vBulletin 4 forum will cease to exist. The databases between 4 and 5 are not compatible.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        So right now I can not do anything to get all my post and user back, unless I try to load my backup of database and run the whole upgrade again?

        Comment


        • #5
          I did use version 4.2.1 and only had this version that I want to upgrade to latest vbulletin connect.

          Comment


          • #6
            You need to start again

            Comment


            • #7
              Can see the sql database still contains all the data. So I understand it was upgraded with some wrong files, but shouldn´t it somehow be possible to fix these files and get this working ?.

              Comment


              • #8
                Well, in that case follow what I said in post #2

                Originally posted by scamtacular View Post
                The /core/includes/config.php file is not meant to be the same as the /config.php file - there will be a config.bak or config.new file at /core/includes - edit it with the correct settings and rename it config.php. Also the /config.php file (the one at the forum root) needs to be set with the correct settings like the core path (yourdomain.com/newforum/core)

                Also if your attachments were stored as files make sure the attachdir folder from the old forum is copied to the root of the new one

                Comment


                • #9
                  Here is my config.php on the root level. Should the $config['core_path' look like this below?

                  <?php
                  /*======================================================================*\
                  || #################################################################### ||
                  || # vBulletin 5 Presentation Configuration # ||
                  || # ---------------------------------------------------------------- # ||
                  || # All PHP code in this file is �2000-2012 vBulletin Solutions Inc. # ||
                  || # This file may not be redistributed in whole or significant part. # ||
                  || # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # ||
                  || # http://www.vbulletin.com | http://www.vbulletin.com/license.html # ||
                  || #################################################################### ||
                  \*======================================================================*/

                  /*-------------------------------------------------------*\
                  | ****** NOTE REGARDING THE VARIABLES IN THIS FILE ****** |
                  +---------------------------------------------------------+
                  | When making changes to the file, the edit should always |
                  | be to the right of the = sign between the single quotes |
                  | Default: $config['admincpdir'] = 'admincp'; |
                  | Example: $config['admincpdir'] = 'myadmin'; GOOD! |
                  | Example: $config['myadmin'] = 'admincp'; BAD! |
                  \*-------------------------------------------------------*/


                  // ****** System Paths ******

                  // This setting allows you to change the name of the admin folder
                  $config['admincpdir'] = 'admincp';

                  // ****** Cookie Settings ******
                  // These are cookie related settings.
                  // This Setting allows you to change the cookie prefix
                  $config['cookie_prefix'] = 'bb';


                  // ****** Special Settings ******
                  // These settings are only used in some circumstances
                  // Please do not edit if you are not sure what they do.

                  // You can ignore this setting for right now.
                  $config['cookie_enabled'] = true;

                  $config['report_all_php_errors'] = false;
                  $config['no_template_notices'] = true;

                  // This setting should never be used on a live site
                  $config['no_js_bundles'] = false;

                  // This setting enables debug mode, it should NEVER be used on a live site
                  $config['debug'] = false;

                  // Assumes default location of core.
                  // These are the system paths and folders for your vBulletin files
                  // This setting is for where your vbulletin core folder is
                  $config['core_path'] = realpath(dirname(__FILE__)) . '/public_html/forum/core';

                  $config['php_sessions'] = false;

                  /*======================================================================*\
                  || ####################################################################
                  || # Downloaded:
                  || # CVS: $RCSfile$ -
                  || ####################################################################
                  \*======================================================================*/

                  Comment


                  • #10
                    Mine is $config['core_path'] = realpath(dirname(__FILE__)) . '/core';

                    As far as I know it gets the current forum URL and sticks /core on the end to get the core path

                    So try setting yours to that - should work

                    Comment


                    • #11
                      OK - so the config in the root must not be changed, as this is the default

                      Comment


                      • #12
                        Keep it as realpath(dirname(__FILE__)) . '/core'

                        In fact, looking through the root config.php nothing should be changed from the default, so all you need to do now is change /public_html/forum/core to /core

                        Comment


                        • #13
                          In vB5.0.4, the only line you should change in the presentation config.php file is the cookie prefix, if needed.

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools &lt;- awesome site for html/css help

                          Comment


                          • #14
                            before I made the try of upgrading to latest version on my site running on "server A" - I made a backup.

                            As the upgrade crashed, I restored the backup to "server b". - where it is running now.

                            Now when I will try again and get the upgrade running on server A - is it possible to move oll posts from "server b" to "server A". Is it is just the "forumpost" table in the sql that must be exported/imported ?

                            Comment


                            • #15
                              Just tried the upgrade once again. The upgrade works fine and everything ok - but again everything empty when trying to open forum - and also no users at all. What is wrong? how can I find the error ?

                              Before running upgrade, I of course edit the "core/includes\config.php file - and also in the root(which I don't modify).
                              Last edited by rtfm1; Tue 13th Aug '13, 12:04pm.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X