Announcement

Collapse
No announcement yet.

vBulletin 4 to 5 Upgrade Gone Bad - Template Looks Horrible and Links are Broken

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin 4 to 5 Upgrade Gone Bad - Template Looks Horrible and Links are Broken

    My web hosting provider did the upgrade for me, but the template looks absolutely horrible. pennyauctionwatch.com/forum as if it's broken completely and links are bad. How do I fix this? "Warning: Invalid argument supplied for foreach() in [path]/admincp/css.php on line 447" is my error message when I go to edit the template. How do I install a new template, is this how to fix it?

  • #2
    This shows on the bottom of the forums page

    Fatal error: Uncaught Database error in vBulletin 5.0.3: [Showing truncated query, original length: 1295308] [First 500 chars] Invalid SQL: /** saveDbCache */ REPLACE INTO cache (cacheid,expires,created,locktime,serialized,data) values ('vb_UserWPerms_2_1', 1374948395, 1374861995, 0, '1', 'a:3:{s:6:\"groups\";a:3:{s:7:\"groupid\";s:1:\"6\";s:9:\"secondary\";a:0:{}s:10:\"infract ion\";a:0:{}}s:3:\"git\";a:8:{i:0;a:2:{s:6:\"nodeid\";i:242069;s:7:\"groupid\";s:2:\"25\"; }i:1;a:2:{s:6:\"nodeid\";i:242072;s:7:\"groupid\";s:2:\"25\";}i:2;a:2:{s:6:\"nodeid\";i:24 2075;s:7:\"groupid\";s:2:\"25\";}i:3;a:2:{s:6:\"nodeid\";i:242076 [Last 500 chars] 49;s:5:\"19243\";i:350;s:5:\"19182\";i:351;s:5:\"17380\";i:352;s:5:\"13477\";i:353;s:5:\"1 5755\";i:354;s:5:\"18688\";i:355;s:4:\"7184\";i:356;s:5:\"15078\";i:357;s:5:\"20401\";i:35 8;s:5:\"19267\";i:359;s:4:\"6563\";i:360;s:5:\"12714\";i:361;s:4:\"8560\";i:362;s:5:\"1428 3\";i:363;s:4:\"4924\";i:364;s:5:\"13381\";i:365;s:5:\"10575\";i:366;s:4:\"4524\";i:367;s: 4:\"8526\";i:368;s in /home/pennyauc/public_html/forum/core/vb/database.php on line 1159

    Comment


    • #3
      You removed all your vBulletin 4.X files prior to the upgrade and you're attempting to use a vBulletin 5 style? Older styles are not compatible.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • jtech77
        jtech77 commented
        Editing a comment
        I didnt do the upgrade Liquidweb did. But I am trying to use the 5 style and as you can see it looks like its' broken? What do I do?

    • #4
      I have disabled products, deleted products, deleted all other templates but default 5, still nothing.

      Comment


      • #5
        You need to make sure your original vBulletin 4 files are not still on the server. VB5 needs a fresh/clean directory, you can't overwrite VB4 ilke you could in previous versions.

        I am fairly certain this is (at least part) of the problem because in VB5 this link should give a "page not found error" - http://pennyauctionwatch.com/forum/ajax.php

        But on your site it's giving me a blank page telling me the file likely still exists from VB4.

        Perhaps your web host was not familiar with the requirements of putting VB5 in a clean directory. Best option would be to rename /forum/ to /forumold/, recreate a clean /forum/ directory, reupload the fresh VB5 files, and finally copy the two config.php files from the old directory to the new one (one is in the /forumold/ directory, the other will be in /forumold/core/includes/)

        Comment


        • #6
          It appears that is what they did because I do not even see a core file.......... Need to find out how to configure the config files in the new directory Im creating?

          Comment


          • #7
            /core/ is a directory not a file.

            You should have right now

            pennyauctionwatch.com/forum/config.php
            and
            pennyauctionwatch.com/forum/core/includes/config.php

            They are two different files. They need to be copied/saved.

            Then rename /forum/ to /forumold/

            Then make a new /forum/

            The upload the vBulletin install files from /UPLOAD/ to /forum/

            Delete the /forum/core/install/ directory (just the /install/ directory, it's not needed)

            Copy the two config.php files back, be sure they are in the correct locations

            If you're lucky everything should work at that point.

            Comment


            • #8
              Ok I did as you suggested and it says
              Couldn't read config file config.php

              Comment


              • #9
                Update I did as you suggested then changed the file permissions to 755 on both config files (as thats what they were in forumold) however still does not render correctly and has the error on the bottom still.. this time:

                Fatal error: Uncaught Database error in vBulletin 5.0.3: [Showing truncated query, original length: 1246340] [First 500 chars] Invalid SQL: /** saveDbCache */ REPLACE INTO cache (cacheid,expires,created,locktime,serialized,data) values ('node_1_lvl1data', 1374968863, 1374882463, 0, '1', 'a:53:{s:6:\"nodeid\";s:1:\"1\";s:7:\"routeid\";s:1:\"4\";s:13:\"contenttypeid\";s:2:\"19\ ";s:11:\"publishdate\";s:10:\"1321982542\";s:13:\"unpublishdate\";s:1:\"0\";s:6:\"userid\" ;s:1:\"2\";s:7:\"groupid\";N;s:10:\"authorname\";N;s:11:\"description\";s:16:\"Home Description\";s:8:\"keywords\";N;s:5:\"title\";s:4:\"Home\";s:9:\"htmltit [Last 500 chars] 49;s:5:\"19243\";i:350;s:5:\"19182\";i:351;s:5:\"17380\";i:352;s:5:\"13477\";i:353;s:5:\"1 5755\";i:354;s:5:\"18688\";i:355;s:4:\"7184\";i:356;s:5:\"15078\";i:357;s:5:\"20401\";i:35 8;s:5:\"19267\";i:359;s:4:\"6563\";i:360;s:5:\"12714\";i:361;s:4:\"8560\";i:362;s:5:\"1428 3\";i:363;s:4:\"4924\";i:364;s:5:\"13381\";i:365;s:5:\"10575\";i:366;s:4:\"4524\";i:367;s: 4:\"8526\";i:368;s in /home/pennyauc/public_html/forum/core/vb/database.php on line 1159

                Comment


                • #10
                  Clear cache in admin cp.

                  Comment


                  • #11
                    I don't know what to do but this is terrible. Been no css since the upgrade...

                    Comment


                    • #12
                      Please disable the modifications and switch back to the vBulletin default style. If the style still is not working properly, re-import the style into the system again.

                      Another think I just noticed is, that when calling up http://www.pennyauctionwatch.com/forum/admincp/, it still says vbulletin 4.2.0. Seems like the upgrade didn't properly work (have you gotten some errors due to the upgrade process) or there are still old vB4 files on your FTP. Make sure that all vB4 files are deleted and only vB5 files are available.
                      No private support, only PM me when I ask for it. Support in the forums only.

                      Comment


                      • #13
                        Originally posted by jtech77 View Post
                        Update I did as you suggested then changed the file permissions to 755 on both config files (as thats what they were in forumold) however still does not render correctly and has the error on the bottom still.. this time:

                        Fatal error: Uncaught Database error in vBulletin 5.0.3: [Showing truncated query, original length: 1246340] [First 500 chars] Invalid SQL: /** saveDbCache */ REPLACE INTO cache (cacheid,expires,created,locktime,serialized,data) values ('node_1_lvl1data', 1374968863, 1374882463, 0, '1', 'a:53:{s:6:\"nodeid\";s:1:\"1\";s:7:\"routeid\";s:1:\"4\";s:13:\"contenttypeid\";s:2:\"19\ ";s:11:\"publishdate\";s:10:\"1321982542\";s:13:\"unpublishdate\";s:1:\"0\";s:6:\"user id\" ;s:1:\"2\";s:7:\"groupid\";N;s:10:\"authorname\";N;s:11:\"description\";s:16:\"Home Description\";s:8:\"keywords\";N;s:5:\"title\";s:4:\"Home\";s:9:\"htmltit [Last 500 chars] 49;s:5:\"19243\";i:350;s:5:\"19182\";i:351;s:5:\"17380\";i:352;s:5:\"13477\";i:353;s:5:\"1 5755\";i:354;s:5:\"18688\";i:355;s:4:\"7184\";i:356;s:5:\"15078\";i:357;s:5:\"20401\";i:35 8;s:5:\"19267\";i:359;s:4:\"6563\";i:360;s:5:\"12714\";i:361;s:4:\"8560\";i:362;s:5:\"1428 3\";i:363;s:4:\"4924\";i:364;s:5:\"13381\";i:365;s:5:\"10575\";i:366;s:4:\"4524\";i:367; s: 4:\"8526\";i:368;s in /home/pennyauc/public_html/forum/core/vb/database.php on line 1159

                        This error specifically is because your Maximum Packet Size in MySQL is 1 MB and the query is larger than 1 MB. We have a JIRA on this issue but to resolve it immediately, you should ask your hosting provider to increase this value to 4 MB. In MySQL 5.6, they have increased the default from 1 MB to 16 MB.

                        I missed this in the first posting of the error.

                        Please see: http://tracker.vbulletin.com/browse/VBV-10306
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment

                        Related Topics

                        Collapse

                        Working...
                        X