Announcement

Collapse
No announcement yet.

vB 5.0.2 Permission Bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vB 5.0.2 Permission Bug

    Hey,

    For some reason, all usergroups can see the first thread of every section, even if they are not allowed to.

    Recently, just after the upgrade, many users had the following issue. When they enter the main page, No Forum Found appears, even if they are allowed to see several sections.

    My forum permissions are set up properly.

    Thanks

  • #2
    Not quite what you mean here...do you mean the "last Post" info on the front page? Or the first topic in the topic listing?

    Screenshot would probably assist here.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Rebuild your permissions by editing the permissions for a single forum and saving it. Then empty your System Cache under Maintenance.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API - Full / Mobile
      Vote for your favorite feature requests and the bugs you want to see fixed.

      Comment


      • #4
        Still having problems, that's the first thing I tried.

        As you can see, someone without access to any of those subforums can see the last thread on them.

        About the No forums found, that happens when a user who does have access to a few sections enters the main page, and no sections or forums are displayed.

        Comment


        • #5
          If you go to Usergroup Manager > edit Unregistered Users, what is set for Can View Channels?

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Have you tried with the Shoutbox and any other mods you have disabled? (Temporarily) Clear the system cache after disabling them.

            Comment


            • #7
              Originally posted by Lynne View Post
              If you go to Usergroup Manager > edit Unregistered Users, what is set for Can View Channels?
              Yes, it's properly set up.

              Disabled all addons.

              Tried to reupload all files, didnt work.

              Tried to re run the upgrade page, this appeared:

              Processing XML. Step 11 to 13.

              <?xml version="1.0" encoding="windows-1252"?> <?xml version="1.0" encoding="windows-1252"?> <error>XML Error: unclosed CDATA section at Line 50436</error> When I moved to vB5 I had the same issue, had to delete all usegroups to get the install process going. Maybe the HTML tags for colors on the usergroup names.
              Last edited by Baigo; Sat 18 May '13, 2:50pm.

              Comment

              Related Topics

              Collapse

              Working...
              X