Announcement

Collapse
No announcement yet.

Fatal Error attempting to log out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal Error attempting to log out

    I'm getting a fatal error when attempting log out of the forum and a similar fatal error when attempting to edit my user profile in the admin panel. The errors are:

    Fatal error: Class 'vB_Datamanager_User' not found in /htdocs/vb5/core/vb/user.php on line 166 (when attempting to log out)

    Fatal error: Class 'vB_Datamanager_User' not found in /htdocs/vb5/core/vb/api/user.php on line 2029 (when attempting to edit user in CP User Manager)

    Up to now everything else seems to be working lol.



  • #2
    Originally posted by humpty View Post
    I'm getting a fatal error when attempting log out of the forum and a similar fatal error when attempting to edit my user profile in the admin panel. The errors are:

    Fatal error: Class 'vB_Datamanager_User' not found in /htdocs/vb5/core/vb/user.php on line 166 (when attempting to log out)

    Fatal error: Class 'vB_Datamanager_User' not found in /htdocs/vb5/core/vb/api/user.php on line 2029 (when attempting to edit user in CP User Manager)

    Up to now everything else seems to be working lol.

    Was that when you were trying to log in to vBulletin.com or your own site? I had a problem yesterday when trying to log in to the forum at vBulletin.com. At first the login field appeared on the left hand side of the page and it wouldn't let me log in until the second attempt. Just replying to this post now I also had a problem; the site showed me as still logged in (with my username at top right) but when I hit "post reply" I got this error message
    "The string you entered for the image verification did not match what was displayed."

    In fact, I hadn't been offered an image verification image and code to fill in; I just typed this reply and got the error message when I tried to post. So I think you may be being a little optimistic when you say everything else seems to be working.

    I could probably live with that if vB5 had a calendar and CMS.

    PS: With pre vB5 installations you used to get an error message if you tried to post when you weren't logged in.

    Comment


    • #3
      This is my own forum - installation went OK but had to add RedirectBase to the htaccess file otherwise everything was all over the place. It's sweet now other than this issue of logging out (no problems logging in) and making changes to my user profile in the ACP. What puzzles me is that if the 'user is not found' how come I can login and do anything lol?

      Comment


      • #4
        Add in now that I cannot add any new user in the ACP without the second error noted above appearing. I tried to add a test user to see if the problem existed and I couldn't even add the user.

        Comment


        • #5
          Please re-upload your /core/ files and see if the problem continues.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            Sorted - heaven knows what happened during the initial upload, but it's working fine now. Many thanks Wayne, much appreciated.

            Comment

            Related Topics

            Collapse

            Working...
            X