Announcement

Collapse
No announcement yet.

Running out of execution time when searching

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running out of execution time when searching

    I get 'Fatal error: Maximum execution time of 60 seconds exceeded in' different filenames, different lines when try to search.

    I can't figure out, how is the search process working. When I search a keyword never searched before, I get this error two-three times, then I get results. Then the new keyword is searchable without any trouble. The search index was rebuilt after upgrades.

    We have as big forum as this site. I'm also experiencing the slow search here.

    Increasing the max_execution_time is not an option for us.

    What happens during the first, second, third search? Is there any way to do that somewhere in admincp?


  • #2
    There's an issue with searching on vB5 whereby there is no pagination, so if you get too many results it's trying to put them all on one page...this will cause errors in many cases.

    Work is being done to correct this for a future version.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      Thanks! We switched to google cse, we need to disable the complete search functionality. I see this in the template:

      Code:
      <vb:if condition="$searchperm AND $vboptions['enablesearches']">
      Where can I set the $vboptions['enablesearches'] to FALSE? I tried
      Code:
      $config['enablesearches'] = FALSE;
      in forum/config.php, but nothing to happen.

      Comment

      Related Topics

      Collapse

      Working...
      X