Announcement

Collapse
No announcement yet.

Is an Installation to root directory possible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is an Installation to root directory possible?

    For several days I try to install the upgrade from vBulletin 5.0.2 directly to root directory. This because I do not want the subfolder is visible in the link. The problem is that the installation or the upgrade fails every time when I try this. So I have missing styles or I can't login to admincp. Because the sub-folders are always mentioned in every guide I wonder if this is possible at all.

    Or asked differently: Is there a way to hide the subfolder when I install to it?

  • #2
    Hi

    Yes you can install to the root, indeed I've seen numerous sites set up this way.

    You need to make sure all the paths in the config files and the admincp are correct, otherwise you'll run into problems.

    You will however still get /forum/ in some of the URLs, this isn't a sub folder as such, it's the channel.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.5.6 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      If your existing site is not in the root directory then you should change the Forum URL in Admin CP -> Settings -> Options -> Site Name / URL / Contact Details to point to the root as the very last step before you upload the upgrade files and run the upgrade script.

      Comment


      • #4
        Unfortunately it dosn't work

        Ok, I tell you my steps.

        My old forum v. 3.8.1 was installed in root directory. Because my provider upgrade to php 5,3 and mysql 5.5 I had to upgrade to version 3.8.7. That works without any problems. The next upgrade to vBulletin v. 4.2.1 works as well (installed in root directory). "CP -> Settings -> Options -> Site Name / URL / Contact" was set to root directory. For the next step to upgrade to 5.0.2 I delete all old files and folders and upload the whole content from "upload" folder to my root directory.

        Then I proceed as follows:

        1. I renamed config.php.bkp to config.php and put my root directory in $config['baseurl'] = 'http://www.effektive-mikroorganismen.eu';
        2. I went to /core/includes/config.php.new and renamed it to config.php
        3. Furthermore, I configured this file as follows:

        $config['Database']['dbname'] = '****'; (the name of my vb 4.2.1 database)
        $config['MasterServer']['username'] = '****'; (the username of my database)
        $config['MasterServer']['password'] = '******'; (password of my database)

        Did I forget something? Because if I proceed this way, I can't login after upgrade to the admincp

        That's my url to admincp: http://www.effektive-mikroorganismen.eu/admincp/

        There is no error message and no entry in error log. I just get the message: "That action could not be completed. Please try again, and if this occurs again please contact the system administrator and tell them how you got this message."

        What am I doing wrong?

        EDIT:

        I just noticed that there is an error message when I navigate to http://www.effektive-mikroorganismen...incp/index.php.


        Warning: require_once(/home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/includes/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/admincp/global.php on line 34

        Fatal error: require_once() [function.require]: Failed opening required '/home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/includes/init.php' (include_path='.:') in /home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/admincp/global.php on line 34

        What could this mean?
        Last edited by kopernikus; Tue 14th May '13, 3:57pm.

        Comment


        • #5
          Your admincp is actually showing up here - http://www.effektive-mikroorganismen.eu/core/admincp/

          In your .htaccess file. Find this line:
          RewriteEngine On

          And right under it, add this:
          RewriteBase /

          See if that fixes the issue (I assume you are running Linux?)

          Please don't PM or VM me for support - I only help out in the threads.
          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
          Want help modifying your vbulletin forum? Head on over to vbulletin.org
          If I post CSS and you don't know where it goes, throw it into the additional.css template.

          W3Schools <- awesome site for html/css help

          Comment


          • #6
            Thank's Lynne, But unfortunately that dosn't fixes the issue. I running windows, but my provider probably run linux.

            Comment


            • #7
              When I turn on the debug mode for loggin, I get this error:

              Warning: fopen(vbdebuglog.log) [function.fopen]: failed to open stream: Permission denied in /home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/core/libraries/log4php/src/main/php/appenders/LoggerAppenderFile.php on line 76

              Fatal error: Call to a member function set() on a non-object in /home/httpd/vhosts/effektive-mikroorganismen.eu/httpdocs/includes/vb5/template/stylevar.php on line 97

              And my error log now say that:

              [Wed May 15 08:58:38 2013] [error] [client xxx.xx.xx.xxx] mod_security: Access denied with code 406. Pattern match "fetch " at THE_REQUEST [severity "EMERGENCY"] [hostname "www.effektive-mikroorganismen.eu"] [uri "/ajax/api/phrase/fetch"]

              EDIT:
              Now, my provider disable mod_security thus the errors in log file are gone, but the problem still persists
              Last edited by kopernikus; Wed 15th May '13, 1:52am.

              Comment


              • #8
                I see an error 500 at this moment, what does the server log say to this?
                No private support, only PM me when I ask for it. Support in the forums only.

                Comment


                • #9
                  Please open /core/includes/config.php. Scroll to the bottom and turn off debuglogging by setting the value to false.. Please do not enable this option unless asked to do so by support.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • #10
                    I activated the debuglogging because I hopped, that someone can locate the source of my problems. This error 500 only occures when debuglogging is activated. Or can anyone see this error at this time? I'm very frustrated. My vBulletin supporter wrote me that he can still see the error in Firebug. My firebug shows me no errors and my webhosting provider tells me, that all working fine. Therefore, the error log is clear. So what can I do? I know that 5.0.2 is working without problems when I install them to a sub directory. But when I put them in root directory, I can't login to admincp. For me it dosn't sounds like a server-side problem. Maybe I'm wrong. So what can I do to fix that problem? I give all information about mysql / ftp passwords already to my supporter. But he ask me every time if I tried this or that. Yes I tried many things an all dosn't work. Why he can’t check some settings itself? I backuped all datas and he can play whatever it takes to fix that problem. Sorry, but after 15 days I'm a little frustrated about this whole situation.

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X