Announcement

Collapse
No announcement yet.

Site Builder does not generate actual links. All links point to # anchor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Site Builder does not generate actual links. All links point to # anchor

    I have installed vbulletin here: http://yourlegaljustice.com/forum/

    I can activate site builder and get the links to appear. However aside from the AdminCP all the links point to "#" and do not let me actually edit any pages. I am trying to make http://yourlegaljustice.com/forum/forum the default home page, but without sitebuilder I don't know how to do this.

    I tried looking at index.php (for content.php to redirect) but I guess that is an old fix.

    I would really like all the features of sitebuilder to be active. Any help would be great... do I need to change any permissions to folders or files? I have not done anything besides running the install.

    Thanks in advance

    Code:
    <ul class="main-nav left">
    <li class="lnkAdminCP"><a href="http://yourlegaljustice.com/forum/admincp/index.php"><span class="icon"></span>AdminCP</a></li> 
    <li class="sb-menu"><a href="#" id="lnkPageManager">Page Manager</a></li> 
     <li><div class="divider"></div></li>
     <li class="sb-menu"><a href="#" id="lnkNewPage">New Page</a></li> 
      <li><div class="divider"></div></li>   
      <li class="sb-menu"><a href="#" id="lnkEditPage">Edit Page</a></li>
         <li><div class="divider"></div></li>   
      <li class="sb-menu"><a href="#" id="lnkHeader">Header</a></li> 
       <li><div class="divider"></div></li>   
      <li class="sb-menu"><a href="#" id="lnkNavBar">Navigation Bar</a></li>    
     <li><div class="divider"></div></li>  
      <li class="sb-menu"><a href="#" id="lnkFooter">Footer</a></li>     <li><div class="divider"></div></li>     
             </ul>

  • #2
    Make sure you're not blocking any of the javascript. Site Builder relies on Javascript to understand what you're doing.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      I have tried in IE, Firefox and Chrome. I have enabled/allowed Javascript checked (I never turn this off) I have allowed pop-ups and even created pop-up block exceptions for my domain. I will gladly share my admin/pass with a Vbulletin technician to make sure I am not crazy.

      Comment


      • #4
        The code you're seeing is actually correct...here's mine:

        Code:
        	<li class="lnkAdminCP"><a href="http://www.talknewsuk.com/forum/admincp/index.php"><span class="icon"></span>AdminCP</a></li>
        	<li class="sb-menu"><a href="#" id="lnkPageManager">Page Manager</a></li>
        	<li><div class="divider"></div></li>
        	<li class="sb-menu"><a href="#" id="lnkNewPage">New Page</a></li>
        	<li><div class="divider"></div></li>
        	<li class="sb-menu"><a href="#" id="lnkEditPage">Edit Page</a></li>
        	<li><div class="divider"></div></li>
        	<li class="sb-menu"><a href="#" id="lnkHeader">Header</a></li>
        	<li><div class="divider"></div></li>
        	<li class="sb-menu"><a href="#" id="lnkNavBar">Navigation Bar</a></li>
        	<li><div class="divider"></div></li>
        	<li class="sb-menu"><a href="#" id="lnkFooter">Footer</a></li>
        	<li><div class="divider"></div></li>
        What happens when you actually click one of these links? Such as "Edit Page".
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.5.2 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          If I am on any page (for instance http://yourlegaljustice.com/forum/blogs) if I click EDIT PAGE it always takes me back to default page with # anchor

          http://yourlegaljustice.com/forum/#

          Comment


          • #6
            Ok...if you want to create me a test admin login and PM me the details, I'll see if I can fathom it out
            (Make it a test one so that afterwardsfor security you can delete it).
            MARK.B | vBULLETIN SUPPORT

            TalkNewsUK - My vBulletin 5.5.2 Demo
            AdminAmmo - My Cloud Demo

            Comment


            • #7
              Thanks, PM sent

              Comment


              • #8
                Ok we think this may be caused by mod_security.
                I have advised accordingly and we'll see if this sorts the problem out.
                MARK.B | vBULLETIN SUPPORT

                TalkNewsUK - My vBulletin 5.5.2 Demo
                AdminAmmo - My Cloud Demo

                Comment

                Related Topics

                Collapse

                Working...
                X