Announcement

Collapse
No announcement yet.

Unique Ad Codes for a large group of forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unique Ad Codes for a large group of forums

    Hi

    Is there any easy way to apply unique ad codes to a group of forums using styles (or any other alternative)?

    I manage a large forum with a hundred+ sub-forums and advertisers like to advertise in specific forums and all their sub-foruns.

    When I use Site Builder the ad placeholders apply across all the forum and not just on specific ones I edited.
    Saving a different page for each forum is not practical as advertisers change frequently

    Thanks
    Pedro
    Last edited by pferreira; Tue 22nd Jul '14, 6:33am.

  • #2
    You can do this but it takes some setup. You need to use Site Builder to do it. Go to one of your forums and click "Edit Page". Then immediately click "Save Page". There will be an option to "Overwrite Template", set this to No and it will ask for a template name. Save your template with a name like "Forum - %FORUMNAME%". Save the page and the template. Now when you create an ad module for this forum, it will only affect this template. You can apply the template to subforums by editing the page, selecting the template off the Template tab and then saving the page.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      Are you on cloud, or the regular download product?

      Comment


      • #4
        Thanks for the answer. I have 2 licences of the downloadable product (for different countries).

        Comment


        • #5
          Originally posted by Wayne Luke View Post
          You can do this but it takes some setup. You need to use Site Builder to do it. Go to one of your forums and click "Edit Page". Then immediately click "Save Page". There will be an option to "Overwrite Template", set this to No and it will ask for a template name. Save your template with a name like "Forum - %FORUMNAME%". Save the page and the template. Now when you create an ad module for this forum, it will only affect this template. You can apply the template to subforums by editing the page, selecting the template off the Template tab and then saving the page.
          Thanks Wayne. When you say "You can apply the template to subforums by editing the page, selecting the template off the Template tab and then saving the page" do you mean on SiteBuilder or on the Admin console?

          Comment


          • #6
            Site Builder.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              Originally posted by Wayne Luke View Post
              You can do this but it takes some setup. You need to use Site Builder to do it. Go to one of your forums and click "Edit Page". Then immediately click "Save Page". There will be an option to "Overwrite Template", set this to No and it will ask for a template name. Save your template with a name like "Forum - %FORUMNAME%". Save the page and the template. Now when you create an ad module for this forum, it will only affect this template. You can apply the template to subforums by editing the page, selecting the template off the Template tab and then saving the page.
              Wayne,
              I am following your instructions but I cannot edit the page.
              When I click the "Edit Page" link on the page I want to edit the pages reloads on the homepage, not the one I want to edit. On the url bar I get "forum_url/#"
              This happens just in some forums, not all of them.

              Am I doing something wrong?

              Comment


              • #8
                Hi Wayne

                The solution doesn't work or seems to have a bug.

                The new template saving with a new name works correctly and It applies correctly to that forum. When I re-edit the page the new template is there with the correct name.

                However, when I change to a new forum and try to apply that same template to another forum, the name is gone. Instead, on the end of the list appears an empty copy of the original template that cannot be applied because it misses system modules.
                Even if I go back to the original forum where the template was created the name doesn't appear any more. Just the empty duplicate of the original template.

                I instanciated a demo to try replicate all the steps and not mess up with my forum but I cannot make it work.

                Can you please help me?
                Regards
                Pedro

                Originally posted by Wayne Luke View Post
                You can do this but it takes some setup. You need to use Site Builder to do it. Go to one of your forums and click "Edit Page". Then immediately click "Save Page". There will be an option to "Overwrite Template", set this to No and it will ask for a template name. Save your template with a name like "Forum - %FORUMNAME%". Save the page and the template. Now when you create an ad module for this forum, it will only affect this template. You can apply the template to subforums by editing the page, selecting the template off the Template tab and then saving the page.
                Last edited by pferreira; Wed 30th Jul '14, 8:05am.

                Comment


                • #9
                  I can't recreate the problem and can edit individual forum pages. You'll need to open a support ticket because if it is redirecting, there is a problem with your configuration and installation.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                  vBulletin 5 Documentation - Updated every Friday. Report issues here.
                  vBulletin 5 API - Full / Mobile
                  I am not currently available for vB Messenger Chats.

                  Comment


                  • #10
                    Hi Wayne
                    I believe is not with my installation because I've tried it with one clean demo instalation (vBulletin 72h demo) and the result was the same.
                    When I go back to another forum to re-apply the template it changed to the original name (so I have a duplicate empty one)

                    (I have an additional issue but I'll put it in a different thread)

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    X