Announcement

Collapse
No announcement yet.

New users complaining that not receiving email registration verification emails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I would at least suggest using the SMTP options available from your webhost.

    SendGrid also has a less than 10k emails per month free plan. A few friends are using it without issues.

    Comment


    • #17
      I'll look into SendGrid, or maybe just use SMTP via my webhost (Hostgator) and report back. This all has something to do with that the word PayPal is included in my forum description title and the gmail system is thinking that the message is coming from someone with the last name PayPal.

      Comment


      • #18
        Another gmail user complained that he did not receive the reg email. I advised him that it might look like that, coming from "PayPal" from hostgator, and he figured it out and confirmed his email.

        Comment


        • #19
          Originally posted by MDawg View Post
          I did a test, and yes I receive them. I tried it with an @cox.net email account recently, and a while back, with a gmail one.
          If you receive them then the users definitely receive them as well. To my knowledge, it's how the system works.

          My guess is it's getting sent to their spam folder.

          I'm encountering the same issue on my site webtechsurface with the email confirmation being sent to the spam folder to where I actually quit doing email confirmation as a whole because of it.

          We may enable it back later but for now it's off. Anyone got any tips for getting the email confirmation to actually appear in the inbox? I could make a separate thread but since it's on topic....

          Thanks.

          Comment


          • #20
            Switch to SMTP of some sort.

            Comment


            • #21
              I know this is not a foolproof solution but you could instruct your users to whitelist your email domain similar to what they did here.


              GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

              Comment


              • #22
                It is on ongoing problem, one guy said he whitelisted and still didn't get it. As well, can't expect someone to whitelist before they even join the forum. I do have a thread up at my forum and as I get people who email me directly and complain about inability to post/PM I refer them to that thread that explains the whole deal, about how they must confirm their email address, the whitelisting, and the weird looking email they might get if they have a gmail.

                The people from @live.com swear they receive nothing - in any form. I don't have an @ live email to test.

                I will look into the SMTP.

                Comment


                • #23
                  I just did a test registration for a hotmail account, no reg email was received.

                  1) How exactly do I implement SendGrid into my forum?

                  2) Or, how do I implement SMTP via hostgator? I can set up a free email account at hostgator. I also have lots of free email accounts available at godaddy.

                  My site is hosted on a hostgator shared server.
                  Last edited by MDawg; Fri 19 Aug '16, 8:19am.

                  Comment


                  • #24
                    OKAY, so I implemented SMTP. For the SMTP host, I used mail.myforum.com and made sure to input the correct SMTP port, username and PW. Non-secure SMPT connection (none). I verified that these settings are correct with hostgator.

                    I must have done it right, because test emails came out and were delivered correctly.

                    However, even though everything is set correctly and now all emails being sent by the forum match the @myforum.com domain name of my forum, still these issues remain:

                    1. Test emails sent to gmail and hotmail are delivered fine. They are formatted corrected and show as coming from [email protected]

                    2. REGISTRATION emails sent to @gmail.com users still arrive with the word "PayPal" as if coming from PayPal. Determined that this is because the word PayPal is part of my forum name. Nothing I seem to be able to do about this.

                    3. Registration emails do not arrive to any @hotmail.com or @outlook.com email. The one slight benefit of implementing SMTP is that now at least, I receive an undeliverable email notice via email that shows that the email was bounced back. This way at least I know when a new hotmail or outlook registrant is not getting his registration confirmation email.

                    The diagnostic code in the bounced email message is: smtp; 550 5.7.0 (COL004-MC6F11) Message could not be delivered. Please ensure the message is RFC 5322 compliant.

                    WHY test emails are being delivered fine and not all registration emails - I still don't know. Hostgator had a theory that it is because I am on a shared server.

                    Comment


                    • #25
                      Shell access? Maybe do a global search for "PayPal".. at your forum root:
                      Code:
                      grep -Hinre 'PayPal' *
                      Then do the same on your database.. search the settings for the value 'PayPal'
                      Code:
                      SELECT * FROM `setting` WHERE value LIKE 'PayPal%' OR defaultvalue LIKE 'PayPal%'
                      Donovan

                      Comment


                      • #26
                        The issue #2 (PayPal as the sender name sent to gmail users) has to do with that the word PayPal is part of my forum name, with commas in the forum name.

                        Reg emails continue to be returned undeliverable universally to outlook and hotmail users, and occasionally to yahoo.

                        Comment


                        • #27
                          Maybe the undeliverable emails are also caused by having Paypal in the sender name. Maybe email providers are blocking the emails as they thought they are spam because they are not sent from an official Paypal email address.

                          GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

                          Comment


                          • #28
                            Well the suggestion made by vbulletin support as far as getting rid of "PayPal" as sender was to remove the commas from my forum name so that the email provider will no longer think that this is like a Last, First name. However, the emails that arrive at yahoo for example (when they do make it) are NOT marked as coming from PayPal so I don't think this is the spam issue. Interesting thought though.

                            Also, the emails marked as coming from "PayPal" are the ones that land in gmail, and those emails do make it, albeit to spam/junk inbox.

                            Comment


                            • Glenn Vergara
                              Glenn Vergara commented
                              Editing a comment
                              Why not try removing Paypal temporarily and then send a diagnostic email and see what happens?

                          • #29
                            Well the weird thing is, all diagnostic emails make it and appear normally as coming from my forum's full name as from [email protected] --- the "PayPal" sender or emails that never make it are the registration emails.

                            In other words, diagnostic emails arrive okay. The reg emails are the ones with issues. Even when a diagnostic email is sent to a certain email address and it tests and arrives fine, if attempting to register a user at same email address the above described issues arise.

                            EXAMPLE:
                            1. Register a user at [email protected]
                            The reg email NEVER arrives. (Also eventually I receive a notification of undeliverable email. The diagnostic code in the bounced email message is pretty much like this: smtp; 550 5.7.0 (COL004-MC6F11) Message could not be delivered. Please ensure the message is RFC 5322 compliant.)
                            2. Send diagnostic email to [email protected]
                            Test email arrives! (although usually to junk/spam)



                            1. Register a user at [email protected]
                            Reg email arrives, usually in spam, with sender indicated as "PayPal" = weird, and PROBLEM!
                            2. Send diagnostic email to [email protected]
                            Test email arrives, with name of sender indicated as "VBulletin Email Test"

                            ---

                            A new weird issue is that I am starting to receive undeliverable/bounced notifications of Reg Emails sent to @yahoo.com but then when I contact the new registrant they tell me they had no problem and received the reg email and clicked on the link...but different error message: (delivery temporarily suspended: lost connection with

                            mta7.am0.yahoodns.net[98.136.XXX.XX] while sending RCPT TO )

                            Last edited by MDawg; Tue 23 Aug '16, 2:09pm.

                            Comment


                            • #30
                              These are really mail provider issues. We are very limited in what support we can provide because vBulletin does not handle emailing itself, it is delegated either to the server or a third party provider via smtp.

                              I would certainly test by removing the word PayPal from the email...I can think of several email providers who would not permit mails like that because they are most commonly going to be spam / spoofs.
                              MARK.B | vBULLETIN SUPPORT

                              TalkNewsUK - My vBulletin 5.6.4 Demo
                              AdminAmmo - My Cloud Demo

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X