Announcement

Collapse
No announcement yet.

New users complaining that not receiving email registration verification emails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New users complaining that not receiving email registration verification emails

    vb 5.2.1

    I don't believe this is a bug, per se, but are others experiencing this issue? I expect that the reg emails are ending up in their spam/bulk folders, but I've gone back and forth with some gmail, outlook and live email users who swear that they have not received it.

    Getting to the point where I'm considering disabling the email reg requirement even at the expense of spammers.

  • #2
    Do you receive them yourself if you set up a test user?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I did a test, and yes I receive them. I tried it with an @cox.net email account recently, and a while back, with a gmail one.

      But these new members no matter where I tell them to look, they swear it's not anywhere, and this is even with gmail users.

      Comment


      • #4
        The most recent registrant is a gmail user, he claims that he did not receive it. He wrote " I asked our webmaster to double check spam filters, Webmail etc and he says the email was never received.

        So I've just tried registering with my Yahoo email account and this has worked fine - email was in the spam filter right away "

        so anyway he states that it did not work for him with gmail, but did with yhoo. I have had other gmail users complain that they are not receiving the reg email too.

        Comment


        • #5
          Do an email diagnostics in AdminCP > Maintenance > Diagnostics > Email. Enter a Gmail address and Send. Then check if the test email is received or not.

          GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

          Comment


          • #6
            I did the test - the email did make it to my yhoo, but not to my gmail test account. I even logged into gmail via webmail and the email was not there, not in Inbox / All Mail or Spam.

            I also tried a private GoDaddy web mail - made it, private Host Gator web mail - made it. And also @cox.net - made it.

            The test email I receive is coming from [email protected]*****.com which is a HostGator hosted email account.

            But for some reason gmail is not receiving these emails, being filtered out. This is a real problem because gmail is very popular.

            Anyone else experienced this?
            Last edited by MDawg; Wed 20 Apr '16, 12:35pm.

            Comment


            • #7
              So it looks like Gmail is blocking emails from your forum. Try whitelisting your forum mail domain in Gmail and try the email diagnostics again.

              GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

              Comment


              • #8
                Yes that worked the email now made it after whitelisting and re-sending it. But can I expect all my forum members to do the same?

                Comment


                • #10
                  I did send the email to google, and not sure if it helped or what happened but I have not had complaints (or at least not many complaints) from gmail users lately about inability to locate the registration email.

                  Comment


                  • #11
                    Good for you. You could try the email diagnostics again to confirm you are receiving forum emails from a Gmail account without whitelisting your domain.

                    GIPHY for vB5 AutoLinker Auto-Create Flag Report Topic Social Icons in Postbit Clear Cache Cron DragDrop Upload Topic AJAX AutoUpdate Custom Avatars Selector Stop Links in Posts...and more!

                    Comment


                    • #12
                      Problem continues. Many gmail users send me direct emails complaining that they are not receiving their registration emails, and then I must go in and switch them over manually to status of Registered User. I ask them to look in their spam/bulk folders, but they claim nothing received. All these gmail users can't be all wrong or blind.

                      I did do a test registration just now, for a gmail user, and the email was marked as coming from "PayPal" ---- ?????

                      Subject " Action Required to Activate Membership for ________"

                      It came from [email protected]

                      what is that? Maybe people are thinking this is some phishing scam or not recognizing the email because it shows as coming from PayPal.

                      Yes my forum is hosted at hostgator but why is it marked as coming from PayPal?

                      Then I did a test email to this same gmail, and the email came through as from [email protected] subject "vBulletin Email Test"

                      ---

                      I did another test registration for a yahoo email user. The registration email eventually went through and this one looked normal, showing as coming from my forum and from [email protected] A test email to this yahoo address also came through as from [email protected] subject "vBulletin Email Test"

                      ---

                      So it is to gmail users that this oddball reg email is coming through appearing to come from PayPal.
                      Last edited by MDawg; Tue 14 Jun '16, 7:17am.

                      Comment


                      • #13
                        What do your SMTP settings look like in the Email settings?

                        Comment


                        • #14
                          Under Email Options, "Set this option to yes to use an SMTP server rather than the internal PHP mail() function." is set to NO.

                          Comment


                          • #15
                            I have seen cases where sites that use their hosting provider as the email source have the from field hijacked in this way. If that's what is happening, you cannot stop it, you would need to use a third party email provider to get round it.
                            MARK.B | vBULLETIN SUPPORT

                            TalkNewsUK - My vBulletin 5.6.4 Demo
                            AdminAmmo - My Cloud Demo

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X