Announcement

Collapse
No announcement yet.

Intermittent failure of direct linking to individual posts within thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    replied
    There is only an option to switch all links to the node variant. This would apply to channels, topics, replies, etc.... Settings -> Options -> Site URLs and Routing has the option to do this.

    Leave a comment:


  • tracks78
    replied
    Thanks Wayne. Is there an easy way to show the node link on a post? We just been clicking the post number and copying the url as it says 'share this post by copy/paste the link'. Or would it be possible to somehow modify on the backend so clicking that post number exposes the node link instead?

    No deleted posts I am aware of on that thread, likely many on one of the others we have had issue with regarding notifications though. If there is an issue with our noderead table is there some documentation we can follow on how to address this?

    Leave a comment:


  • Wayne Luke
    replied
    I am guessing that you have deleted posts in that topic. The reason I say this is because the post 48 link above takes me to #43. Post 49 takes me to #44. However, the nodeids match in your examples. Relying on post numbers and page numbers for links will pretty much fail. Users can specify a different number of posts per page and will see different numbers of posts depending on what is soft deleted or needs approval within a topic.

    It may be a better method to use a node link to link to specific nodes in your system. So something like https://electricbike.com/forum//node/127057 for the first link and https://electricbike.com/forum/node/127928 for the second link.

    Notifications will send you to the first unread post all the time. If it is sending you to an incorrect node, then you might have a problem with your noderead table.

    Leave a comment:


  • Intermittent failure of direct linking to individual posts within thread

    We have seen this several times both on threads and especially on notifications lately (maybe unrelated idk) but here is an example.

    We typically use threads like below for technical documentation with the first post continually updated with links to the individual posts, like a directory. This has mostly worked fine for years, but sometimes, not so much. If you look at page 4 here, the two posts at the bottom (posts 48 and 49) cannot be direct linked, if you do, it takes you to the top of page 3. Direct linking to any other post in this thread works fine.

    These are the actual URLs of the post, that would typically work correctly.

    post 48

    post 49


    On a perhaps related note we sometimes see similar issue on certain threads when we get new post notification. Particularly problematic is a post from 2017 that happens to be 282 pages long and still very actively used. Often when I get a notification about posts or comments in that thread, if I click the notification it will send me to some page a hundred pages earlier in the thread.




Related Topics

Collapse

  • Karmann
    Diplaying recent posts
    by Karmann
    Hi

    I'm getting complaints from my regular users that it's not easy finding new content. I have created this link

    http://www.sunddebat.com/search?searchJSON={%22date%22%3A%22lastVisit%22%2C%22view%22%3A%22topic%22%2C%22unread_onl y%22%3A1%2C%22sort%22%3A{%22lastcontent%22%3A%22desc%22}%2C%22exclude_type%22%3A[%22vBForum_PrivateMessage%22]}...
    Wed 2 Sep '15, 10:32am
Working...
X