The date of the messages is not displayed (the time is)

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • infoplc
    New Member
    • Aug 2008
    • 14
    • 3.7.x

    The date of the messages is not displayed (the time is)

    I have a problem in my forum. The date of my messages has not been displayed for a long time but the time does:

    The correct format is: Date, Time
    My format is: (NOTHING), Time

    Attached image with the problem. Can someone tell me where the error is?

    Thanks!

  • In Omnibus
    Senior Member
    • Apr 2010
    • 2308

    #2
    What is in the field under Format For Date in the AdminCP>Settings>Options>Date And Time Options?

    Comment

    • Wayne Luke
      vBulletin Technical Support Lead
      • Aug 2000
      • 73412
      • 6.0.X

      #3
      Is this the Spanish translation? If so, there is a bug that is causing the dates to not show.

      Please update the date fields under Languages & Phrases -> Language Manager -> Spanish -> Edit Settings. With the bug it says %x for date format override, this is not a valid value. Set it to something like %y-%m-%d. If you look at the description for this field, there is a link to the date format diagnostic that lists all options if you desire something different.
      Last edited by Mark.B; Sun 10 Jan '21, 5:05am. Reason: Added closing var tag.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment

      • infoplc
        New Member
        • Aug 2008
        • 14
        • 3.7.x

        #4
        Thanks for the reply

        Yes, it does use the Spanish version.

        If I access Languages & Phrases -> Language Manager -> Spanish -> Edit Settings> Invalidate date format>

        I have tried: Change %x for new [var]%y-%m-%d

        Click image for larger version

Name:	11.jpg
Views:	115
Size:	26.3 KB
ID:	4452253

        But it does not visualize it well
        Click image for larger version

Name:	12.jpg
Views:	84
Size:	12.6 KB
ID:	4452254

        Then i tried: Change [var]%y-%m-%d for new %d-%m-%y

        Click image for larger version

Name:	21.png
Views:	83
Size:	11.1 KB
ID:	4452255

        But keep visualizing the same

        Click image for larger version

Name:	12.jpg
Views:	84
Size:	12.6 KB
ID:	4452254‚Äč

        I have also tried to put %X again but it keeps displaying [var]%y-%m-%d

        Thanks!!!

        Comment

        • Mark.B
          vBulletin Support
          • Feb 2004
          • 24275
          • 6.0.X

          #5
          I think Wayne may have missed a closing tag off his code. Apologies.

          Set it to:

          %y-%m-%d
          MARK.B
          vBulletin Support
          ------------
          My Unofficial vBulletin 6.0.0 Demo: https://www.talknewsuk.com
          My Unofficial vBulletin Cloud Demo: https://www.adminammo.com

          Comment

          • infoplc
            New Member
            • Aug 2008
            • 14
            • 3.7.x

            #6
            Hello Mark

            Thanks for your answer, I have modified the code now I have put %y-%m-%d but in the front of the forum it keeps showing me [var]% y-% m-%

            Click image for larger version

Name:	12.jpg
Views:	89
Size:	12.6 KB
ID:	4452277


            It seems as if it did not accept the change and has been stuck with this code [var]% y-% m-%

            Thanks!

            Comment

            • w4term4n
              Senior Member
              • May 2013
              • 140
              • 5.5.x

              #7
              Originally posted by infoplc
              Hello Mark

              Thanks for your answer, I have modified the code now I have put %y-%m-%d but in the front of the forum it keeps showing me [var]% y-% m-%

              Click image for larger version

Name:	12.jpg
Views:	89
Size:	12.6 KB
ID:	4452277


              It seems as if it did not accept the change and has been stuck with this code [var]% y-% m-%

              Thanks!
              Hello Spanish friend xD, I have it like this:

              Click image for larger version

Name:	esp1.JPG
Views:	82
Size:	144.7 KB
ID:	4452283
              Click image for larger version

Name:	esp2.JPG
Views:	78
Size:	65.4 KB
ID:	4452284
              Attached Files

              Comment

              • infoplc
                New Member
                • Aug 2008
                • 14
                • 3.7.x

                #8
                Thanks for share your configuration


                As much as I change this parameter: Languages & Phrases -> Language Manager -> Spanish -> Edit Settings> Invalidate date format>

                the forum it keeps showing me [var]% y-% m-%

                Comment

                • Wayne Luke
                  vBulletin Technical Support Lead
                  • Aug 2000
                  • 73412
                  • 6.0.X

                  #9
                  Clear your system cache in the AdminCP under Maintenance.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment

                  • infoplc
                    New Member
                    • Aug 2008
                    • 14
                    • 3.7.x

                    #10
                    Yessss! It is working correctly!

                    Thanks everyone for your help!

                    Comment

                    Related Topics

                    Collapse

                    Working...
                    😀
                    😂
                    🥰
                    😘
                    🤢
                    😎
                    😞
                    😡
                    👍
                    👎