Announcement

Collapse
No announcement yet.

upgraded to SSL and having issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • online68
    replied
    Thank you!!!!!!!!!!!!

    Leave a comment:


  • Wayne Luke
    replied
    Yes.

    Leave a comment:


  • online68
    replied
    Oh, so do I just remove the # from those two lines?

    Leave a comment:


  • Wayne Luke
    replied
    vBulletin 5 ships with a .htaccess file that is required for the software to be used properly. You shouldn't have to create a new one. Just edit the one that already exists.

    Leave a comment:


  • online68
    replied
    Thanks, Wayne. So, I had basically created a .htaccess file and put this info in it as per the GoDaddy link that was shared in the SSL instructions that I had previously linked to:
    Code:
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    Are you saying that I should change the three lines to:
    Code:
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    Just want to make sure I'm doing this the right way. Basically, these are the only three lines that are in the .htacess file that I created and put on my site.
    Last edited by online68; Wed 24 Jan '18, 10:42am.

    Leave a comment:


  • Wayne Luke
    replied
    The issue is caused when users visit http://yoursite.com instead of https://yoursite.com. Due to the security placed on the cookies in vBulletin 5, these are seen as two completely different sites and therefore do not share cookies. We will only write cookies for https://yoursite.com if that is how the system is configured.

    There are two lines in the .htaccess provided with the latest versions of vBulletin that can help. You need to uncomment them.

    Change this:
    Code:
    #To redirect users to the secure version of your site, uncomment the lines below 
    #RewriteCond %{HTTPS} !=on
    #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    To this:
    Code:
    #To redirect users to the secure version of your site, uncomment the lines below 
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
    If that doesn't redirect them properly, you will have to request that your hosting provider fix the issue. All requests to http://yoursite.com should be automatically redirected to http://yoursite.com

    Leave a comment:


  • online68
    started a topic upgraded to SSL and having issues

    upgraded to SSL and having issues

    Hello. I'm hoping that someone can help me out. I'm a novice and I don't know much about this sort of stuff.

    I followed the instructions here: https://www.vbulletin.com/forum/arti...forum-to-https
    and did everything that it said, but now I'm getting emails from members that they're having issues. Not all members are having issues; just some of them.

    The few that are having issues state that when they login the forum appears as if they haven't logged in and gives them the message that they don't have permission to view that page. Others are telling me that their bookmark for the url isn't working (but I thought that everything that I did would redirect the old http to the new https).

    I'm not having any issues at all.

    Any suggestions?

Related Topics

Collapse

Working...
X