No announcement yet.

Index of/admincp white page

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Resolved] Index of/admincp white page

    OK so I upgraded 4.2.5 to 5.3. Set up a new directory and database. Ran the upgrade and all went just fine. Clicked on the link at the end of the upgrade to enter the admincp.

    I can't get into the admincp! All I get at the top of the page is "Index of /50/admincp" and a link "parent directory" which when clicked goes to what I assume would be the index page for the forum. It is all askew...see here

    I have searched and come up with threads about blank pages and the like, tried to go into debug as instructed and other suggestion to no avail. Even went to the error logs and nothing is there. Maybe I am just to thick headed and can't comprehend the instructions properly.

    With that said, can someone please tell me where to begin in plain simple detailed English so this bone head can grasp the instructions?

    Server Type Linux
    Web Server Apache (cgi-fcgi)
    PHP 7.1.4
    MySQL Version 5.5.51-38.2

    Got that info from the original 4.2.5 admincp

    Have tried in Chrome and Fire Fox many times and yes cleared history and cashe in both.
    Evil abounds when good people do nothing!

  • #2
    Two important things:

    1. Make sure you have renamed htaccess.txt to .htaccess (note the dot at the front)
    2. If your test install is operating on a different URL, did you change the URL settings in the admincp beforehand?

    You might be able to get into admincp temporarily to change these settings by going to
    However, if not you will need to use tools.php:

    1) Upload /core/install
    2) Upload tools.php in your do_not_upload directory to /core/admincp
    3) Run /core/admincp/tools.php in your browser and enter your customer number
    4) Go to Other Tools > Location of Website
    5) Enter the correct URL, make sure the core URL option is ticked, and save
    6) Verify that the site loads ok
    7) Delete /core/admincp/tools.php
    8) Delete /core/install
    9) Verify that the admincp works ok, WITHOUT /core/ in the URL
    vBulletin Support


    • #3
      Thank you Mark. It was the htaccess file. No where did I see that needed to be changed. Working fine now!
      Evil abounds when good people do nothing!


      • #4
        Renaming the .htaccess is mentioned in numerous places -If you think it should be mentioned somewhere else, please let me know.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API


        • In Omnibus
          In Omnibus commented
          Editing a comment
          Is there a good reason why the htaccess and config files aren't named correctly in the upload package?

        • Mark.B
          Mark.B commented
          Editing a comment
          Yes...if they were, every time someone upgraded the existing files would be overwritten and the customer would need to make all the changes again.

          It's been like this since at least vBulletin 2.

        • Wayne Luke
          Wayne Luke commented
          Editing a comment
          Their current names prevent catastrophic failures on upgrades. Imagine if you had to have your hosting provider add an Apache handler to the .htaccess for a proper version. Now we've overwritten it and you don't know how to fix it.

      Related Topics