Announcement

Collapse
No announcement yet.

Video Embed Stopped working on all my sites version 5.3.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Bug / Issue] Video Embed Stopped working on all my sites version 5.3.1

    Video Embed Stopped working on all my sites, I noticed this after I upgraded from 5.2.? to 5.3.1 but I am not sure if this is related.
    The youtube link is there within all the post and there is a picture from the video there with the play button in the center but when you click the play button nothing happens.

    Here is 2 of my sites that has this problem.
    http://www.gonejetskifishing.com/for...rip-07-05-2015

    http://www.kf4eok.com/forum/forum/ma...in-nassauville

    I have tried clearing my cash. I have made new post with a youtube video and it dose not work. http://www.kf4eok.com/forum/forum/su...g-area/634-121

    I do not know about other videos, I only use youtube. I have also tried the default VB theme with the same result.

    My PHP version is 5.6.30

    Has anyone else had this problem? Everything else seems to be working ok within the forum.

    Dose anyone have any ideas where I should start looking to resolve this problem?

    Thanks for your help.
    Last edited by kf4eok; Mon 12 Jun '17, 3:49pm.
    http://www.thestarquestclub.com/forums/forum.php

  • #2
    Your Facebook Connect is failing. If you turn that off, do the videos start working?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Following Wayne Lukes guide I put one of my sited into debug mode and clicked on one of the video links and here is the results from the network tab.
      Headers:
        1. Request URL:
          http://www.gonejetskifishing.com/aja...r/bbcode_video
        2. Request Method:
          POST
        3. Status Code:
          200 OK
        4. Remote Address:
          107.180.41.87:80
        5. Referrer Policy:
          no-referrer-when-downgrade
      1. Response Headersview source
        1. Cache-Control:
          max-age=0,no-cache,no-store,post-check=0,pre-check=0
        2. Connection:
          keep-alive, Keep-Alive
        3. Content-Encoding:
          gzip
        4. Content-Length:
          50
        5. Content-Type:
          application/json; charset=UTF-8
        6. Date:
          Mon, 12 Jun 2017 22:52:48 GMT
        7. Expires:
          Sat, 1 Jan 2000 01:00:00 GMT
        8. Keep-Alive:
          timeout=5
        9. Last-Modified:
          Mon, 12 Jun 2017 22:52:48 GMT
        10. Pragma:
          no-cache
        11. Server:
          Apache/2.4.25
        12. Vary:
          Accept-Encoding,User-Agent
        13. X-Powered-By:
          PHP/5.6.30
      2. Request Headersview source
        1. Accept:
          application/json, text/javascript, */*; q=0.01
        2. Accept-Encoding:
          gzip, deflate
        3. Accept-Language:
          en-US,en;q=0.8
        4. Connection:
          keep-alive
        5. Content-Length:
          99
        6. Content-Type:
          application/x-www-form-urlencoded; charset=UTF-8
        7. Cookie:
          bbpassword=8fbf7d44f00a323ee06cea2b9e2fb931375124e4a89c71cf35019413; bbuserid=1; bbshowcketoolbar=1; PHPSESSID=fmotlq07kcb2u6se33ofus97a3; bbuserstyleid=11; bbcpsession=a6d081f02d14fb35e32128729bff85a9; bbsessionhash=ee94f9231e9d4b29031ba039724a630b; _ga=GA1.2.55070562.1492026836; _gid=GA1.2.1255226468.1497246624; bbdiscussion_view=%7B.85.-1497305648%2C.168.-1497299059%2C.210.-1497305662%2C.220.-1497305249%2C.1770.-1497307321%7D
        8. Host:
          www.gonejetskifishing.com
        9. Origin:
          http://www.gonejetskifishing.com
        10. Referer:
          http://www.gonejetskifishing.com/for...rip-07-05-2015
        11. User-Agent:
          Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
        12. X-Requested-With:
          XMLHttpRequest
      3. Form Dataview sourceview URL encoded
        1. code:
          KdN4Tflkzes
        2. provider:
          youtube
        3. securitytoken:
          1497305676-ca70f4c786987b227726bcba07384b9ea8814fc

      and here is the response tab results:
      {"template":"","css_links":[]}


      I hope this helps.
      http://www.thestarquestclub.com/forums/forum.php

      Comment


      • #4
        Thanks, I had already retrieved that information from your links.

        If you disable your Facebook Connect, do your video embeds work?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          I went to cp / options / facebook options and turned off enable facebook options and the videos still will not play when clicked.

          What do you mean my My Facebook Connect is failing? Do I have another problem that I need to be looking at?
          http://www.thestarquestclub.com/forums/forum.php

          Comment


          • #6
            the only addon or products that I have on my forum is:

            forum runner
            RepliClock
            http://www.thestarquestclub.com/forums/forum.php

            Comment


            • #7
              I have tried Microsoft Edge, FireFox and Chrome all with the same results.
              http://www.thestarquestclub.com/forums/forum.php

              Comment


              • #8
                I have looked at the bbcode_video in the database and they looks the same as my working site.
                http://www.baymeadowscommunitycounci...es-af/506-test
                http://www.thestarquestclub.com/forums/forum.php

                Comment


                • #9
                  I have compared my .htaccess file to my working site and they are the same as my working site.

                  <IfModule mod_rewrite.c>
                  RewriteEngine On

                  # In some cases where you have other mod_rewrite rules, you may need to remove the
                  # comment on the following RewriteBase line and change it to match your folder name.
                  # This resets the other mod_rewrite rules for just this directory
                  # If your site was www.example.com/forum, the setting would be /forum/
                  #RewriteBase /

                  #To redirect users to the secure version of your site, uncomment the lines below
                  #RewriteCond %{HTTPS} !=on
                  #RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

                  # Send css calls directly to the correct file VBV-7807
                  RewriteRule ^css.php$ core/css.php [NC,L]

                  # Redirect old install path to core.
                  RewriteRule ^install/ core/install/ [NC,L]

                  # Main Redirect
                  RewriteCond %{REQUEST_URI} !\.(gif|jpg|jpeg|png|css)$
                  RewriteCond %{REQUEST_FILENAME} !-f
                  RewriteCond %{REQUEST_FILENAME} !-d
                  RewriteRule ^(.*)$ index.php?routestring=$1 [L,QSA]

                  # Because admincp is an actual directory.
                  RewriteRule ^(admincp/)$ index.php?routestring=$1 [L,QSA]

                  </IfModule>

                  <IfModule mod_deflate.c>
                  AddOutputFilterByType DEFLATE application/atom+xml \
                  text/javascript \
                  application/x-javascript \
                  application/javascript \
                  application/json \
                  application/rss+xml \
                  application/vnd.ms-fontobject \
                  application/x-font-ttf \
                  application/xhtml+xml \
                  application/xml \
                  font/opentype \
                  image/svg+xml \
                  image/x-icon \
                  text/css \
                  text/html \
                  text/plain \
                  text/x-component \
                  text/xml
                  </IfModule>

                  <IfModule mod_expires.c>
                  ExpiresActive On
                  ExpiresByType application/x-javascript A1209600
                  ExpiresByType text/javascript A1209600
                  ExpiresByType application/javascript A1209600
                  ExpiresByType text/css A31536000
                  ExpiresByType image/x-icon A2592000
                  ExpiresByType image/icon A2592000
                  ExpiresByType application/x-ico A2592000
                  ExpiresByType application/ico A2592000
                  ExpiresByType image/gif A2592000
                  ExpiresByType image/jpeg A1209600
                  ExpiresByType image/jpg A1209600
                  ExpiresByType image/png A1209600
                  ExpiresByType application/x-shockwave-flash A1209600
                  ExpiresByType font/ttf A2592000
                  ExpiresByType font/otf A2592000
                  ExpiresByType font/x-woff A2592000
                  ExpiresByType image/svg+xml A2592000
                  ExpiresByType font/truetype A2592000
                  ExpiresByType font/opentype A2592000
                  ExpiresByType application/x-font-woff A2592000
                  ExpiresByType application/vnd.ms-fontobject A2592000
                  </IfModule>

                  <IfModule mod_headers.c>
                  Header set Connection keep-alive
                  <filesmatch "\.(ico|flv|gif|swf|eot|woff|otf|ttf|svg)$">
                  Header set Cache-Control "max-age=2592000, public"
                  </filesmatch>
                  <filesmatch "\.(jpg|jpeg|png)$">
                  Header set Cache-Control "max-age=1209600, public"
                  </filesmatch>
                  <filesmatch "\.(eot|woff|otf|ttf|svg)$">
                  Header set Cache-Control "max-age=2592000, public"
                  </filesmatch>
                  # css and js should use private for proxy caching https://developers.google.com/speed/...geProxyCaching
                  <filesmatch "\.(css)$">
                  Header set Cache-Control "max-age=31536000, private"
                  </filesmatch>
                  <filesmatch "\.(js)$">
                  Header set Cache-Control "max-age=1209600, private"
                  </filesmatch>
                  </IfModule>
                  RewriteCond %{HTTP_HOST} ^kf4eok\.com$ [OR]
                  RewriteCond %{HTTP_HOST} ^www\.kf4eok\.com$
                  RewriteRule ^/?$ "http\:\/\/www\.kf4eok\.com\/forum" [R=301,L]
                  http://www.thestarquestclub.com/forums/forum.php

                  Comment


                  • #10
                    All the bbcode_video_vbulletin.xml files are the same on all three forums.

                    <?xml version="1.0" encoding="ISO-8859-1"?>
                    <!-- vBulletin 5.2.6 Alpha 1 -->
                    <video_bbcode>
                    <provider tagoption="hulu">
                    <title>Hulu</title>
                    <url>http://www.hulu.com</url>
                    <regex_url><![CDATA[https?:\/\/www\.hulu\.com\/watch\/]]></regex_url>
                    <regex_scrape><![CDATA[<link rel="media:video" href="https?:\/\/www\.hulu\.com\/embed\.html\?eid=([^"]+)"]]></regex_scrape>
                    <embed><![CDATA[<object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />512</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />296</vb:if>" data="http://www.hulu.com/embed/{vb:raw code}">
                    <param name="movie" value="http://www.hulu.com/embed/{vb:raw code}" />
                    <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
                    </object>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="youtube">
                    <title>YouTube (Long)</title>
                    <url>http://www.youtube.com</url>
                    <regex_url><![CDATA[https?:\/\/www\.youtube\.com\/watch\?.*v=([a-z0-9-_]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1" allowFullScreen></iframe>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="youtube_share">
                    <title>YouTube (Short)</title>
                    <url>http://youtu.be</url>
                    <regex_url><![CDATA[https?:\/\/youtu\.be\/([a-z0-9\-_]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<iframe class="restrain" title="YouTube video player" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />390</vb:if>" src="//www.youtube.com/embed/{vb:raw code}?wmode={vb:raw vboptions.player_wmode}&autoplay=1" allowFullScreen></iframe>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="vimeo">
                    <title>Vimeo</title>
                    <url>http://www.vimeo.com</url>
                    <regex_url><![CDATA[https?:\/\/(?:www\.)?vimeo\.com\/([0-9]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />640</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />360</vb:if>" data="http://vimeo.com/moogaloop.swf?clip_id={vb:raw code}&autoplay=1">
                    <param name="movie" value="http://vimeo.com/moogaloop.swf?clip_id={vb:raw code}" />
                    <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
                    </object>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="dailymotion">
                    <title>Dailymotion</title>
                    <url>http://www.dailymotion.com</url>
                    <regex_url><![CDATA[https?:\/\/www\.dailymotion\.com(?:\/[^\/]+)?\/video\/([a-z0-9]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />420</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />339</vb:if>" data="http://www.dailymotion.com/swf/{vb:raw code}?autoPlay=1">
                    <param name="movie" value="http://www.dailymotion.com/swf/{vb:raw code}" />
                    <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
                    </object>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="metacafe">
                    <title>Metacafe</title>
                    <url>http://www.metacafe.com</url>
                    <regex_url><![CDATA[http:\/\/www\.metacafe\.com\/watch\/([0-9a-z_\-\/]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />400</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />345</vb:if>" data="http://www.metacafe.com/fplayer/{vb:raw code}.swf">
                    <param name="movie" value="http://www.metacafe.com/fplayer/{vb:raw code}.swf" />
                    <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
                    <param name="flashVars" value="playerVars=autoPlay=yes" />
                    </object>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="google">
                    <title>Google</title>
                    <url>http://video.google.com</url>
                    <regex_url><![CDATA[http:\/\/video\.google\.com\/videoplay\?docid=([0-9\-]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<object class="restrain" type="application/x-shockwave-flash" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />400</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />326</vb:if>" data="http://video.google.com/googleplayer.swf?docid={vb:raw code}&autoplay=1">
                    <param name="movie" value="http://video.google.com/googleplayer.swf?docid={vb:raw code}" />
                    <param name="wmode" value="{vb:raw vboptions.player_wmode}" />
                    </object>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="facebook">
                    <title>Facebook (Legacy)</title>
                    <url>http://www.facebook.com</url>
                    <regex_url><![CDATA[https?:\/\/www\.facebook\.com\/(?:video\/video|photo)\.php\?v=([0-9]+)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<iframe src="https://www.facebook.com/video/embed?video_id={vb:raw code}" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />576</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />432</vb:if>" frameborder="0" allowFullScreen></iframe>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    <provider tagoption="facebook_2017">
                    <title>Facebook</title>
                    <url>http://www.facebook.com</url>
                    <regex_url><![CDATA[https?:\/\/www\.facebook\.com\/((?:[^\/]+)\/videos\/[0-9]+\/?)]]></regex_url>
                    <regex_scrape></regex_scrape>
                    <embed><![CDATA[<iframe src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2F{vb:urlencode {vb:raw code}}&show_text=0" width="<vb:if condition="isset($width) AND $width > 0">{vb:raw width}<vb:else />576</vb:if>" height="<vb:if condition="$height">{vb:raw height}<vb:else />432</vb:if>" frameborder="0" allowFullScreen></iframe>]]></embed>
                    <priority>-1</priority>
                    </provider>
                    </video_bbcode>
                    http://www.thestarquestclub.com/forums/forum.php

                    Comment


                    • #11
                      I have noticed that the site that is still working is version vBulletin 5.3.1 Alpha 2.
                      http://www.baymeadowscommunitycounci...es-af/506-test

                      I do not want to upgrade this above site until I figure out what is going on with these two sites.
                      http://www.kf4eok.com/forum/forum/suggestions-testing-area/testing-area/634-121
                      http://www.gonejetskifishing.com/forum/jet-ski-fishing/jet-ski-fishing-videos/1770-jet-ski-fishing-trip-07-05-2015


                      I have spent hours looking at the files on the server and comparing them with no results.
                      I have also looked at my settings on all the sites and have not noticed any differences that would cause the problem.

                      Is there any way to downgrade the two sites to 5.3.1 Alpha 2 to see if that would help solve the problem?

                      I see that 5.3.1 Alpha 2 is not available to download but 5.3.0 is. Can I install these files then run upgrade.php to downgrade the forums?
                      Is something like this possible?
                      Last edited by kf4eok; Tue 13 Jun '17, 4:46am.
                      http://www.thestarquestclub.com/forums/forum.php

                      Comment


                      • #12
                        Downgrade paths are not provided. You can try running the 5.3.0 files against your current database. I don't think it will cause any issues.

                        If you edit a post with embedded videos and save that post without making any changes do the videos work?
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          I did edit a post and the video still dose not work.
                          http://www.gonejetskifishing.com/for...rip-07-05-2015
                          http://www.thestarquestclub.com/forums/forum.php

                          Comment


                          • #14
                            I uploaded the files for 5.3.0 and run the update.php and it did not complete.
                            I then re uploaded the files for 5.3.1 and run the upgrade.php and now the embedded video works as it should.
                            Thanks for all the help.
                            http://www.thestarquestclub.com/forums/forum.php

                            Comment


                            • #15
                              I also started a ticket on this issue and would like to close the ticket but cannot figure out where to do this. if someone can close the ticket for me or tell me where I can do it I will close it.
                              http://www.thestarquestclub.com/forums/forum.php

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X