Problem after moving posts

  • Time
  • Show
Clear All
new posts
  • shining
    • Mar 2017
    • 56
    • 5.2.x

    Problem after moving posts

    Hi there,

    today was the first time I had to move 3 posts from a thread in "public" forum into a forum channel, which can only be seen by moderator and admin. Don´t want to delete them yet...

    Now I have the problem, that these 3 posts (answers and comments) can still be seen by other users in search result when the search module "show" is set to "standard", though they are now in another forum channel. When users click on it, they don´t see them in the original thread.

    AND I found out a really weird thing:
    In this process, where I tried to hide the 3 posts from other users, I changed the source in the search module from forum (including all forums) to only a few forum channels.
    There is no problem when I visit the page with the search module as an admin. The search module on the page shows me all latest posts (answers and comments)

    But for any other user it is shown like the "thread-view". They don´t see the latest answers and comments one by one. The standard-view appears like thread-view.

    When I set the search module back and just click on "all forums" as the source, all users can see standard.

    I also tried to "rebuild the search index". Does not help with the 3 moved posts. They still show up in search results for all users. I did get an database error by doing this via email

    Database error in vBulletin 5.3.0:
                                            Invalid SQL:
    INSERT INTO searchtowords_s (`nodeid`,`wordid`,`is_title`,`score`,`position`) VALUES (511,283,0,10000,11) /**searchtowords_s**/;
                                            MySQL Error   : Duplicate entry '283-511' for key 'wordid'
                                            Error Number  : 1062
                                            Request Date  : Tuesday, April 18th 2017 @ 05:06:38 PM
                                            Error Date    : Tuesday, April 18th 2017 @ 05:06:38 PM
                                            Script        :
                                            Referrer      :
                                            IP Address    :
                                            Username      : xx-Admin
                                            Classname     : vB_Database_MySQLi
                                            MySQL Version : 5.5.47-MariaDB
    Are these known issues?
  • Wayne Luke
    vBulletin Technical Support Lead
    • Aug 2000
    • 73427
    • 6.0.X

    The error is stating that a record for that word already exists and the query is failing.

    Search results are cached so even if you move them, users can see the cached results until the cache expires. You can clear the system cache in the AdminCP to see if this clears up the modules for you.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API


    • shining
      • Mar 2017
      • 56
      • 5.2.x

      Originally posted by Wayne Luke
      You can clear the system cache in the AdminCP to see if this clears up the modules for you.
      No, unfortunately not.. thats what I tried first.
      And thats why I had the idea that maybe rebuilding the search index could help.

      Now I have deleted the post... and they don´t show up anymore in search results. Was a solution this time, but sometimes its better to be able to keep such posts as a kind of "evidence".


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.