Announcement

Collapse
No announcement yet.

impossible to link to sub-channel from URL created at navigation bar

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • impossible to link to sub-channel from URL created at navigation bar

    Dear Sirs,


    I want the menu entry TRADING CHANNELS to link to the channel URL below, but it's just not possible. I've managed to add a new link to the Navigation Bar for other channels in the forum, but it's just impossible to do it with the channel I call below "Supply and demand Swing and Position Trading Rooms".

    I am using 5.2.0

    I copied the URL from the channel below and pasted it in the Navigation bar option, like I did with other main menu navigation entries, this one will NOT work.

    You can check this problem at http://www.set-and-forget.com/

    Press on Trading Channels and the main forum with all channels will be seen, but it's pointing at the URL to the channel I want which is http://www.set-and-forget.com/forum/...-trading-rooms as seen in the attached screenshot.

    I did the same thing on other channels and added URLs to the navigation bar and they work great but not this one. What is the problem with this channel? How can I fix it? If you click on that channel name it will not load the sub-channels which is what I want, I don't want to display the whole forum's channels again, I want to filter the channels out and display only the sub-channels in that channel. Like I said, I've done this successfully with other channels but this one particularly won't work. I can't show you the other channels that work because they are only visible to registered members.

    What can be the problem? I am lost

    Thanks in advance.
    Regards,
    Alfonso

  • #2
    The routing is broken in some way.
    Have you renamed it at any point? As the name of the channel doesn't match the URL.

    I would also upgrade to 5.2.4 as soon as you can.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.7.0 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • panoramia
      panoramia commented
      Editing a comment
      I don't think I renamed the channel Mark. I've just installed 5.2.4 but the problem is still there. Is there a way I can rename the URL or name of the channel so that it links exactly where I want?

      That menu navigation should only display the channels within that sub-channel, as it does in all other main menu navigation entries I've added. If the link is broken for whatever reason that goes beyond my comprehension, how can I edit/rename the channel name so that it links correctly? I just don't know how to do it.

      Thanks in advance.

  • #3
    You changed the URL to use underscores instead of the default hyphens. It's better for SEO to use hyphens over underscores. Read this blog:

    http://www.ecreativeim.com/blog/2011...-for-seo-urls/

    GIPHY for vB5 AutoLinker Auto-Create Flag Report INITIALS AVATAR (Better) Name Card Quote Selected Text Likes Summary Disable AJAX Pagination Stop Links in Posts...& MORE!

    Comment


    • panoramia
      panoramia commented
      Editing a comment
      Thanks a lot for the tip regarding the underscore, it makes sense. The thing is that it does not change the fact that for whatever reason the sub-channels are not being displayed. I have tried with - and _ and nothing. I just don't know what I need to do in order to have an URL in the navigation bar to link to a channel to display only the sub-channels in that channel. I've done it in a couple of channels and it works, but not on this one Thanks

  • #4
    How did you rename the URL of that channel? The routing for that channel looks broken in some way as what Mark said.

    GIPHY for vB5 AutoLinker Auto-Create Flag Report INITIALS AVATAR (Better) Name Card Quote Selected Text Likes Summary Disable AJAX Pagination Stop Links in Posts...& MORE!

    Comment


    • panoramia
      panoramia commented
      Editing a comment
      I had not renamed it, I installed 5.2.4 and stopped working. So now I've tried to rename it with EDIT PAGE and changing the URL at the end of the process. Then edited the navigation bar to link to the new page, but the same... the sub-channels are not displayed, the link displays all forums and I don't know how to fix that so I can only see the sub-channels under the main channel (category). I just don't know which exact steps to follow to do it, I can't find any help in the instructions or the forum, which is why I am asking... You and Mark told me that the URL seems broken but how can I unbreak it or fix it? That's what I don't know, the steps I need to follow Thanks in advance.

    • glennrocksvb
      glennrocksvb commented
      Editing a comment
      This would require looking into your setup which only Support can do.

Related Topics

Collapse

Working...
X