Announcement

Collapse
No announcement yet.

Can't log in to Admin CP all of a sudden

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by MDawg View Post
    I posted in the JIRA.

    I REVERTED THE PATCH, WENT BACK TO PHP 5.6.24 AND FACEBOOK INTEGRATION/LOGIN WAS RESTORED. So this VBV-16318.patch does not seem to be a complete solution.
    Thank you for your feedback. It will be tested during the normal process. The patch was released outside that process to provide an immediate work around to customers.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #32
      I can't download the file..
      I entered my email in 'Priority Support' and waited a few hours.

      Comment


      • #33
        Originally posted by etemiz View Post
        I can't download the file..
        I entered my email in 'Priority Support' and waited a few hours.
        What happens when you try?
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.7.1 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • IggyP
          IggyP commented
          Editing a comment
          not sure what all is in play here, but someone else told me this also and requested i email them the file...fwiw

      • #34
        All right I got the file now. (Another day and another computer.)
        Now my problem is I can't install. I am on Windows and there is no 'patch' command line utility.

        Comment


        • #35
          Patch for Windows - http://gnuwin32.sourceforge.net/packages/patch.htm
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #36
            Originally posted by Wayne Luke View Post
            Does that work in Windows 7 and 10? The last update for that was in 2007 and the latest version in the requirements says Vista.

            Btw, I recently installed the vB 5.2.3 patch on Windows and I just applied the changes to the files manually. It was not that hard as there are only few files and few changes per file.

            GIPHY for vB5 AutoLinker Auto-Create Flag Report INITIALS AVATAR (Better) Name Card Quote Selected Text Likes Summary Disable AJAX Pagination Stop Links in Posts...& MORE!

            Comment


            • #37
              The Windows Command line hasn't changed much in the last couple of decades. I don't see why it wouldn't work. If you're using Windows 10, you can install the Linux on Windows subsystem from the Programs and Features control panel and get BASH as your command line. It has patch available. There are also other options like cygwin.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • William Thomas Jr
                William Thomas Jr commented
                Editing a comment
                May I ask why this patch must applied by such process as necessary? That is, most patches are just uploaded to the root directory and replace files in Vbulletin 5. Why this method now?

              • glennrocksvb
                glennrocksvb commented
                Editing a comment
                I think because the patch is not an official "PL" patch release.

              • Wayne Luke
                Wayne Luke commented
                Editing a comment
                It isn't a patch level release. It is a file that changes the code of your existing files before the fix is actually released in vBulletin. The fix will properly be applied when you upgrade to 5.2.4.

            • #38
              I have upgraded to vb 5.2.4 and reverted to PhP 7.0.9 on my shared hostgator server - people are able to login normally and Facebook integration including the Like button is working normally!

              Comment


              • #39
                Thanks for the update.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #40
                  Not that I would think otherwise, but just in case that old patch is still doing something - and I did "revert" the patch - since I uploaded all the new vb 5.2.4 components I don't need to worry about any old components/code modifications from that interim VBV-16318.patch remaining, do I? (I also went ahead and deleted that patch off the server.)

                  I checked these components one by one and they show as modified today:
                  core/vb/request.php
                  core/vb/ip.php
                  core/vb/session/webapi.php
                  core/vb/session/api.php
                  core/vb/session/web.php

                  Comment


                  • #41
                    Originally posted by MDawg View Post
                    Not that I would think otherwise, but just in case that old patch is still doing something - and I did "revert" the patch - since I uploaded all the new vb 5.2.4 components I don't need to worry about any old components/code modifications from that interim VBV-16318.patch remaining, do I? (I also went ahead and deleted that patch off the server.)

                    I checked these components one by one and they show as modified today:
                    core/vb/request.php
                    core/vb/ip.php
                    core/vb/session/webapi.php
                    core/vb/session/api.php
                    core/vb/session/web.php
                    Patches for 5.2.3 that changed php files are overwritten since when you upgrade, you overwrite all the files.

                    GIPHY for vB5 AutoLinker Auto-Create Flag Report INITIALS AVATAR (Better) Name Card Quote Selected Text Likes Summary Disable AJAX Pagination Stop Links in Posts...& MORE!

                    Comment


                    • #42
                      Okay, thanks! That's what I thought but just checking.

                      Comment

                      Related Topics

                      Collapse

                      • saiff
                        Invalid SQL: SELECT `varname`,`languageid`,`text` FROM phrase
                        by saiff
                        What is this error?



                        Invalid SQL:
                        SELECT `varname`,`languageid`,`text` FROM phrase
                        WHERE `varname` IN ('Description cannot be empty. Please set this field.','go_back','my_profile','my_recent_posts','user_settings','log_out','logo','search' ,'filter_search','navbar_home','navbar_blogs','navbar_articles','navbar_social_groups','na vbar_158516011593_15751604158916081585','navbar_15751604157816081575160216101593','navbar_ 15781586161016101606_15751604160516081575159016101593','navbar_newtopics','navbar_todays_p osts','navbar_whos_online','navbar_mark_channels_read','navbar_member_list','search_in_tit les_only','advanced_search','notice_23_html','navbar_help','navbar_contact_us','go_to_top' ,'powered_by_vbulletin','footer_current_time','working_ellipsis','yes','no','ok','cancel')...
                        Tue 25 Apr '17, 5:14am
                      • mittac
                        Error log
                        by mittac
                        [20-Oct-2017 00:42:08 Europe/Minsk] PHP Warning: Illegal string offset 'starter' in public_html/includes/vb5/template.php(318) : eval()'d code on line 167
                        [20-Oct-2017 00:42:08 Europe/Minsk] PHP...
                        Fri 20 Oct '17, 12:49am
                      • saiff
                        Warning: Illegal string offset
                        by saiff
                        hi,
                        when viewing some members blog, get this error

                        [16-Apr-2017 10:10:15 Asia/Riyadh] Warning: Illegal string offset 'moderatorperms' in /home/usre/public_html/vb/includes/vb5/template.php(318)...
                        Sun 16 Apr '17, 1:48am
                      • adkaush
                        Warning: array_key_exists() expects parameter 2 to be array, null given in ..
                        by adkaush
                        Forum version: vBulletin 5.3.0 Connect
                        PHP version: 5.6
                        1. The forum was working absolutely fine till last night (IST). Now after 8 hours I visited the forum and got a couple of warnings right up
                        ...
                        Tue 25 Jul '17, 7:02pm
                      • 2TrakR
                        Assistance with SQL error
                        by 2TrakR
                        Randomly getting the following SQL error. Different users. I'm having difficulty determining "what" is wrong. I believe it is indicating a thumbnail image is the cause, but if so, I can't determine...
                        Thu 9 Aug '18, 6:29am
                      Working...
                      X