Announcement

Collapse
No announcement yet.

Members posting and it going into 'Private Message'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BarkyJ
    replied
    Originally posted by Glenn Vergara View Post
    Try this temporary solution while waiting for the actual fix. Add the below CSS in css_additional.css template or in Sitebuilder > Style > CSS Editor for the target style/theme.

    Code:
    [COLOR=#FF0000].page33[/COLOR] #content:before {
    content: "Sorry, you are not authorized to view this page.";
    }
    [COLOR=#FF0000].page33[/COLOR] .canvas-layout-container {
    visibility: hidden;
    }
    That should display an error message when viewing /special/private-messages page and hide the actual content.

    Change page33 to whatever page id the Private Messages page is using. You can find it in the class attribute of the <body> tag. Right click and choose "Inspect" and look for the body tag and you will find the pageXX in the class attribute.

    Code:
    <body id="vb-page-body" class="l-desktop [COLOR=#FF0000]page33[/COLOR] vb-page view-mode" itemscope itemtype="http://schema.org/WebPage" data-usergroupid="60">

    OK I did this via Site Builder, Syles, CSS for the style we use, etc.
    Found the page was page34, and so applied that to page34.
    It stops /special being opened now, however /special/private-messages still displays the same, and has a New Topic button still.

    hmm

    Tried multiple styles, all the same. Seems to have no effect at all.
    Last edited by BarkyJ; Fri 6 May '16, 4:20pm.

    Leave a comment:


  • BarkyJ
    replied
    Originally posted by Glenn Vergara View Post
    Try this temporary solution while waiting for the actual fix. Add the below CSS in css_additional.css template or in Sitebuilder > Style > CSS Editor for the target style/theme.

    Code:
    [COLOR=#FF0000].page33[/COLOR] #content:before {
    content: "Sorry, you are not authorized to view this page.";
    }
    [COLOR=#FF0000].page33[/COLOR] .canvas-layout-container {
    visibility: hidden;
    }
    That should display an error message when viewing /special/private-messages page and hide the actual content.

    Change page33 to whatever page id the Private Messages page is using. You can find it in the class attribute of the <body> tag. Right click and choose "Inspect" and look for the body tag and you will find the pageXX in the class attribute.

    Code:
    <body id="vb-page-body" class="l-desktop [COLOR=#FF0000]page33[/COLOR] vb-page view-mode" itemscope itemtype="http://schema.org/WebPage" data-usergroupid="60">

    My brain just exploded.
    Ill digest this and see if its something I can implement.
    Thank you.

    Leave a comment:


  • BarkyJ
    replied
    Originally posted by Wayne Luke View Post

    Don't let unverified users post or use private messages.
    That is already the case, which is what makes it even weirder.

    Leave a comment:


  • glennrocksvb
    replied
    Try this temporary solution while waiting for the actual fix. Add the below CSS in css_additional.css template or in Sitebuilder > Style > CSS Editor for the target style/theme.

    Code:
    [COLOR=#FF0000].page33[/COLOR] #content:before {
        content: "Sorry, you are not authorized to view this page.";
    }
    [COLOR=#FF0000].page33[/COLOR] .canvas-layout-container {
        visibility: hidden;
    }
    That should display an error message when viewing /special/private-messages page and hide the actual content.

    Change page33 to whatever page id the Private Messages page is using. You can find it in the class attribute of the <body> tag. Right click and choose "Inspect" and look for the body tag and you will find the pageXX in the class attribute.

    Code:
    <body id="vb-page-body" class="l-desktop [COLOR=#FF0000]page33[/COLOR] vb-page view-mode" itemscope itemtype="http://schema.org/WebPage" data-usergroupid="60">

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by BarkyJ View Post
    Its not like users just go and post there, its always new users, typically before they have read the instructions and clicked the email link to activate their account. Unsure how they find where to post though.
    This has happened probably 6 times I can think of, all different users.
    Don't let unverified users post or use private messages.

    Leave a comment:


  • BarkyJ
    replied
    Thanks Trevor

    Just had yet another person post in the same area just in the last hour.
    So weird!

    Leave a comment:


  • Trevor Hannant
    replied
    I've raised a bug to have access to those 'channels' routed to the correct part of the software:

    http://tracker.vbulletin.com/browse/VBV-15989

    Leave a comment:


  • BarkyJ
    replied
    Its not like users just go and post there, its always new users, typically before they have read the instructions and clicked the email link to activate their account. Unsure how they find where to post though.
    This has happened probably 6 times I can think of, all different users.

    Leave a comment:


  • Mark.B
    replied
    Originally posted by BarkyJ View Post
    Right, I understand.
    But why can you go to somewhere like this, and be presented with a 'New Topic' button?
    http://www.vbulletin.com/forum/special/private-messages

    I just posted a message in there on this forum. See what result you get.
    I would like to disable this so no one can post here, as its totally usless for all involved to have a post wind up in there. You cant move it, you cant read it, the only way you see the content is from the email that is sent (if you have that enabled), from what I can tell.
    There is no way to disable it....it is not exposed anywhere in the user interface, so no users would ever find it.
    If you have someone who is actually posting messages there, instruct them to stop doing so as it is not a correct place to post. If they don't comply, try denying them access to Private Messages....that will probably stop them from being able to post in that channel but will also stop them sending PMs. If they complain, tell them it's because they refused to stop posting somewhere that you asked them not to, and they can have PM access back when they stick to the rules.

    Leave a comment:


  • BarkyJ
    replied
    Right, I understand.
    But why can you go to somewhere like this, and be presented with a 'New Topic' button?
    http://www.vbulletin.com/forum/special/private-messages

    I just posted a message in there on this forum. See what result you get.
    I would like to disable this so no one can post here, as its totally usless for all involved to have a post wind up in there. You cant move it, you cant read it, the only way you see the content is from the email that is sent (if you have that enabled), from what I can tell.

    Leave a comment:


  • Wayne Luke
    replied
    It is used behind the scenes so users can send private messages to each other by clicking on "Messages" in the top right corner of the page.

    Every single vBulletin 5 installation has the Special channel and its sub-channels. In fact your installation won't work properly without them.

    Leave a comment:


  • BarkyJ
    replied
    Everything has been provided in the ticket.

    We are not trying to do anything special. Alot of features are turned off, we don't even allow galleries or anything like that on our site. I am unsure what the purpose of this Private Messages page would be or why there is even a page, even if not visible. I have no idea how a customer could get to it though. I set up a new account and tried to find where to get there and simply couldn't find anything.

    Leave a comment:


  • Wayne Luke
    replied
    Yes, I know. It shouldn't be publically accessible unless people are trying to do things they aren't. It isn't linked directly anywhere.

    Like I told the customer, we need access to their site to see if there is an actual problem.

    Leave a comment:


  • glennrocksvb
    replied
    There's actually a Private Messages channel under Special.

    http://www.vbulletin.com/forum/special/private-messages
    Click image for larger version

Name:	Capture.PNG
Views:	39
Size:	60.1 KB
ID:	4342640


    I don't know what that's for but definitely that's not for the actual Private Messages page.

    Leave a comment:


  • Wayne Luke
    replied
    Sending to that URL is only available on the messages page. Like I said, we need to see the database to see if there is actually a problem.

    Leave a comment:

Related Topics

Collapse

Working...
X