No announcement yet.

"The File You Are Trying To Upload Is Corrupted" Message

  • Filter
  • Time
  • Show
Clear All
new posts

  • "The File You Are Trying To Upload Is Corrupted" Message

    Some of our users are starting to experience this message when they try to upload images. They are under the max file size, and are the proper image format. There appears to be no rhyme or reason for which images get the corrupt message. This is new. Is this a bug?

  • #2
    The most likely cause is that it is an image type that doesn't match the extension of the image. Since code can be inserted into images, we check this. It is not new but improper naming is becoming more commonplace as the browsers will look inside an image instead of relying on the extension or metadata these days.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API


    • #3
      I am getting same error

      The file you are trying to upload is corrupted.

      Exception trace:

      ## E:\****\forum-alpha\core\vb\library\content\attach.php(555) Exception Thrown

      #0 E:\****\forum-alpha\core\vb\api\content\attach.php(504): vB_Library_Content_Attach->uploadAttachment('1', Array, true, false)

      #1 E:\****\forum-alpha\core\vb\api\content\attach.php(344): vB_Api_Content_Attach->uploadAttachment(Array)

      #2 E:\****\forum-alpha\core\vb\api\wrapper.php(201): vB_Api_Content_Attach->upload(Object(stdClass))

      #3 E:\****\forum-alpha\includes\api\interface\collapsed.php(101): vB_Api_Wrapper->__call('upload', Array)

      #4 E:\****\forum-alpha\includes\vb5\frontend\controller\uploader.php(677): Api_Interface_Collapsed->callApi('content_attach', 'upload', Array)

      #5 E:\****\forum-alpha\includes\vb5\frontend\controller\uploader.php(790): blueImpUploadHandler->handle_file_upload('F:\\temp\\phpB68E...', 'baaghi3-28.jpg', 58316, 'image/jpeg', 0)

      #6 E:\****\forum-alpha\includes\vb5\frontend\controller\uploader.php(305): blueImpUploadHandler->post()

      #7 E:\****\forum-alpha\index.php(74): vB5_Frontend_Controller_Uploader->actionUpload()

      #8 {main}


      Not able to upload attachments.

      Please help, I have upgraded version 4.2.5 to 5.5.6.


      • #4
        The same advice may apply.....if you upload the attachment to this site, does it work?

        TalkNewsUK - My vBulletin 5.7.1 Demo
        AdminAmmo - My Cloud Demo


        • #5
          Thanks Mark, it worked.

          But getting now customavatars display issue, custom avatar is not showing even though it uploaded in directory & save in customavatars table in database.

          Dont know why its taking default avatar always.

          please help
          Last edited by AV_whiz; Sun 26 Apr '20, 12:07am.


          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.