No announcement yet.

Problem with Image attachment resize - broken links

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Image attachment resize - broken links


    I'm having strange problems with some JPG files. The problem is that when I add Thumbnail, Small, Medium or Large resized image in the post, not all of this choices insert pictures. Some of them are just icon for broken link.

    Thumbnail always work ok even if I set thumbnail size to 1280!
    Small works with 1/3 of my files.
    Medium almost never works.
    Large - never.

    I have prepared two files for example and the strangest thing is that the smaller file in size and resolution is the one with the problems. I can provide many more jpg files with this problem; it’s not a broken file.
    It seems that all the JPGs from my Sony 24mp camera works, but not the files from my even Fuji 16mp camera and my friends Pentax.

    The files can be downloaded from here:

    There is no problem with 24mp.jpg file but the 16mp.jpg file is problematic.

    Here are my settings:

    Message Attachment Options
    Limit Space Taken Up By Attachments (Total) = 0
    Attachment Upload Inputs = 1
    Attachment URL Inputs = 1
    Allow Deletion of Attachments Beyond Edit Time Limit = no
    Allow Deletion of Attachments in Closed Topics = no
    Allow Duplicate Attached Images = no
    Resize Images = yes
    View Attached Images Inline = yes, display thumbnail
    Thumbnail Creation = yes, with dimensions
    Thumbnail Quality = 85
    Thumbnails Per Row = 5
    Thumbnail Color = #000000
    Asset Manager - Enable = Yes, Ajax Upload by Default
    Asset Manager - Assets per Page = 20
    Advanced Insert Image Popup - Enable = Yes
    Attachment Resize Options
    Icon = 32
    Thumbnail = 200
    Small = 400
    Medium = 800
    Large = 1280

    Attachment Type Manager
    Extension jpg
    Maximum file size: 20240000
    Max Width: 10000
    Max Height: 8000

    Nothing modified in Attachment Permissions Manager

    Server Type Linux Users to Moderate 0 [View]
    Web Server Apache v2.2.15 Topics to Moderate 0 [View]
    PHP 5.5.31 Posts to Moderate 0 [View]
    PHP Max Post Size 100.00 MB MySQL Version 5.1.73
    PHP Maximum Upload Size 100.00 MB MySQL Packet Size 16.00 MB
    PHP Memory Limit 512.00 MB
    Number of Queued E-Mails 0

    Any ideas?

    The forum address is:
    Account can be created for the test.

    p.s. I have tested this also on my friend’s vB5 site, on a different Linux, different administrator and the problem is also present!

  • #2
    I have also tested:
    Options>Image Settings>Image Processing Library = GD
    Options>Image Settings>Image Processing Library = ImageMagick 6

    Attachments>Attachment Storage Type = Database
    Attachments>Attachment Storage Type = File System

    I have also run everithing under "Maintance" in AdminCP
    Message Attachment Options > [Rebuild all attachments] link under "Attachment resize options"

    Nothing seems to make any difference.


    • #3
      I do not know if it is connected to my main problem but Resize images is also not working:
      Resize Images = Yes
      (If an image is larger than your maximum allowed dimensions or file-size, an attempt to resize it will be tried.
      This may fail if the image is too large to be successfully processed or if the image type is not supported for
      resizing. When this option is enabled, you should limit the Attachment Input options above to one, otherwise
      the uploading of multiple large images by one user could strain your server.)

      If I lower my limits and try to upload bigger imahe it is not resized and I get an error message that I must resize it manualy.


      • #4
        just to confirm...are you in fact inserting from attachment and not album? i have notice an issue like this when trying with albums but there are still a few too many issue for me to determine whats causing what


        • #5
          Yes, but it does not matter from were I insert the picture. Even if I upload it in the albums and then insert it in a new image in another post and configure Medium or Large display it got broken.

          I have not found any workaround for uploading the 16mp image and setting it display in Medium or Large, so that when someone clicks on it it can be open in full size.


          • #6
            Originally posted by sabink View Post
            Yes, but it does not matter from were I insert the picture. Even if I upload it in the albums and then insert it in a new image in another post and configure Medium or Large display it got broken.

            I have not found any workaround for uploading the 16mp image and setting it display in Medium or Large, so that when someone clicks on it it can be open in full size.
            that is exactly what i am saying will not work must insert this content as attachments to do this atm, or manually add "&type=medium" to the end of the album link....inserting album content via links is broken

            wow those are definately some wide open image settings tho, i wonder if that more likely has to do with the issue...10000width x 8000height??? which you expect the software to convert to 800 but i dont think it will do that??

            regarding making the images links....if you insert them as attachents(paperclip icon) they will be links....otherwise, that also has to be manually coded sigh, by making the image a link in the content also(chain icon)


            • #7
              Thanks for trying to help!

              The big limits are for testing purposes only. It does not matter if they are big or small, image are never resized anyway.

              As I pointed out I have provided two files and the problem is ONLY with the small one (16mp.jpg). The BIG one (24mp.jpg) is working just fine. It does not matter if I insert as attachment or gallery, 24mp.img is always working and 16mp.img is never working.

              BTW Even on this forum there are bugs when uploading an image.

              If I try to upload my 16mp.jpg image using the landscape icon I get this message: "Your file of 3970103 bytes exceeds the limit of 3145728."

              Then if I browse again and press "send to server" button I do not get the error message, but a forum page in a one line window embedded in the Image Properties window.

              I better create a video to demonstrate...


              • #8
                Here is a video showing how it's working fine with the big file:

                Here is a video showing how it's NOT working with the small file:


                • #9
                  Sorry, but I just read the requirement for posting info. Here is the info required:
                  1. vBulletin Version - 5.2.0 Patch Level 1
                  2. PHP Version - 5.5.31
                  3. MySQL Version - 5.1.73
                  4. Any Addons installed - No
                  5. Does the issue occur in a default style? - YES
                  6. Does the issue occur using the English language provided? - YES
                  7. Error message on the screen' - Broken image icon
                  8. Browser and Browser version used. - Chrom Version 48.0.2564.97 m and Firefox 44.0
                  9. A list of steps that can be used to recreate the issue. - Provided in video and text


                  • IggyP
                    IggyP commented
                    Editing a comment
                    hmm that mysql pretty dated...not sure how much that could add to issue tho, i see its still technically within minimum requirements but i would upgrade that
                    Last edited by IggyP; Tue 2 Feb '16, 12:52pm.

                • #10
                  Here is one more resized picture insert bug, but this time it's on this forum. I do not know if it is related...

                  I'm not sure anymore if I made the right decision buying vBulletin.
                  The system seems to me too buggy!
                  I hope that the support will be adequate and my problems are going to be resolved quickly.


                  • #11
                    No solution so far. I have also posted a ticket, but no respond there either for 7 days now!!!

                    Does anyone know how long usually support tickets are answered? Is there any faster way to receive support?

                    I guess I'm lucky I didn't have some urgent problem...


                    • #12
                      There is a setting in the /core/includes/config.php file for maximum height and width of allowed images. Images larger in any dimension are discarded.

                      The code in recent versions of VB5 look like:

                          // ******** IMAGE PROCESSING OPTIONS ********
                          // Images that exceed either dimension below will not be resized by vBulletin.
                          // If you need to resize larger images, alter these settings.
                      $config['Misc']['maxwidth'] = 4608;
                      $config['Misc']['maxheight'] = 3456;
                      But you can/should increase those values if you are attempting to upload larger images.


                      • #13
                        Joe, thanks for the reply. This solved the problem with the images not being resized on upload, but the problem with inserting different sizes in a post still remains.


                        I have inserted an image (above) in this post and then double clicked on it and selected medium size and it changes to broken link. The picture was displaying correctly at full size.

                        You can download the image from

                        Try it on your forum and find where is this bug is hiding
                        Last edited by sabink; Tue 9 Feb '16, 7:37am.


                        • #14
                          I'm able to use the image as any size on my test site. Can you confirm you are using the GD image library?

                          Also, what is you PHP Memory Limit? I would suggest at least 128 M.

                          Click image for larger version

Name:	vb5-image-test-sizes.jpg
Views:	268
Size:	135.4 KB
ID:	4338149


                          • #15
                            I was using ImageMagic, but I switched to GD for the test.

                            It is not working, only the Full size is ok on my side.
                            PHP 5.5.31
                            PHP Max Post Size 100.00 MB
                            PHP Maximum Upload Size 200.00 MB
                            PHP Memory Limit 512.00 MB
                            It is not working on this site also. Can you insert it in this tread as a new post? It's not working for me. Did you download the picture from the link I provided or you saved it from my post?


                            Related Topics