Announcement

Collapse
No announcement yet.

Problems after moving from DB to Filesystem Storage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems after moving from DB to Filesystem Storage

    Hi, I’m getting a bunch of these emails every day since switching from Database storage to Filesystem and now can’t access articles and blog posts or any attachments. When trying to get into a blog post or article I get 504 Gateway Time out, web server is not responding.

    Database error in vBulletin 5.1.1:

    Invalid SQL:
    SELECT * FROM vb_cache
    WHERE `cacheid` IN ('stylevar_cache_1');

    MySQL Error : MySQL server has gone away
    Error Number : 2006
    Request Date : Monday, August 25th 2014 @ 08:03:29 AM
    Error Date : Monday, August 25th 2014 @ 08:11:54 AM
    Script : http:///articles/219-turbo-cool-down-time
    Referrer : http://www.classicrv.net/articles
    IP Address : 192.99.153.46
    Username : Guest
    Classname : vB_Database_MySQLi
    MySQL Version :


    Transfer went fine so I finalized it, all 198 attachments are now in /attachments folder on server. Cannot access attachments now and can’t upload new ones.

    www.classicrv.net
    1. vB version 5.1.1
    2. MySQL version 5.5.35-cll-lve
    3. PHP version 5.4.31
    4. Add ons installed:
      1. DragonByte Tech: AJAX Threads (Lite)
      2. PostMan Notification
      3. Forum Runner
      4. VigLink
    5. Issue occurs in default style
    6. Issue occurs using English
    7. Errors
      1. Error when trying to upload an attachment http://screencast.com/t/6VG7W2mHdLxx
      2. Blank when trying to view an attachment
    8. Firefox 31.0

    1. Request URL:

    http://www.classicrv.net/articles/21...cool-down-time
    1. Request Headers
      1. Provisional headers are shown
      2. Accept:

    text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
    1. Referer:

    http://www.classicrv.net/articles
    1. User-Agent:

    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

    Response Tab says “Failed to load Response Data”
    1. Remote Address:

    23.229.147.7:80
    1. Request URL:

    http://www.classicrv.net/images/css/...adient.php.png
    1. Request Method:

    GET
    1. Status Code:

    404 Not Found
    1. Request Headersview source
      1. Accept:

    image/webp,*/*;q=0.8
    1. Accept-Encoding:

    gzip,deflate,sdch
    1. Accept-Language:

    en-US,en;q=0.8
    1. Connection:

    keep-alive
    1. Cookie:

    bbsessionhash=206201b204ebca59787e030333f5bb48; bblastvisit=1409157451; PHPSESSID=92b8fa82d570f04931361cdc8b2fbe61; bbannouncements_displayed=%7B.1.-1%7D; _ga=GA1.2.1528496136.1409157507; bblastactivity=1409157970
    1. Host:

    www.classicrv.net
    1. Referer:

    http://www.classicrv.net/forums
    1. User-Agent:

    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

    Response Headersview source
    1. Cache-Control:

    no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    1. Connection:

    keep-alive, Keep-Alive
    1. Content-Type:

    text/html
    1. Date:

    Wed, 27 Aug 2014 16:46:19 GMT
    1. Expires:

    Thu, 19 Nov 1981 08:52:00 GMT
    1. Keep-Alive:

    timeout=5
    1. Pragma:

    no-cache
    1. Server:

    Apache mod_fcgid/2.3.10-dev
    1. Set-Cookie:

    bblastactivity=1409157979; path=/; httponly
    1. Transfer-Encoding:

    chunked
    1. X-Powered-By:

    PHP/5.4.31
    1. X-UA-Compatible:

    IE=edge,chrome=1

    Response:

    <!DOCTYPE html>
    <html id="htmlTag" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" xml:lang="en-US" lang="en-US" dir="ltr">
    <head>
    <base href="http://www.classicrv.net/" />

    <link rel="Shortcut Icon" href="http://www.classicrv.net//favicon.ico" type="image/x-icon" />

  • #2
    I'd suggest upgrading to 5.1.2
    Also, check with your webhost to see what the MySQL max_packet_size is, it should be at LEAST 4MB.

    Comment


    • #3
      Packet size is 32MB according to admincp.

      Was scared to do the upgrade while something is wrong for fear of making it worse. It's ok to do upgrade now while having these issues?

      Comment


      • #4
        Trying to upgrade to 5.1.2 and getting "MySQL server has gone away" on step 18.

        Comment


        • #5
          Truncate your cache and cacheevent tables.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API

          Comment


          • #6
            I have confirmed that MySQL max packet size is 32MB. Can you point me in the right direction as to how to do that Wayne? I have googled and searched and am not clear on where to do that.

            Comment


            • #7
              Run these queries on the database:

              truncate table cache;
              truncate table cacheevent;

              You can run queries within the vBulletin Admin Control Panel by going to Maintenance -> Execute SQL Queries.

              To run Queries in the Admin Control Panel you need to edit your config.php file and add your user ID to the Can Run Queries section. It looks like:

              // ****** USERS WITH QUERY RUNNING PERMISSIONS ******
              // The users specified here will be allowed to run queries from the control panel.
              // See the above entries for more information on the format.
              // Please note that the ability to run queries is quite powerful. You may wish
              // to remove all user IDs from this list for security reasons.
              $config['SpecialUsers']['canrunqueries'] = '';

              Place your user id between the single quotes.

              If you can't get into the AdminCP, then you will need to use the tool that your host gives you access to. Usually phpMyAdmin.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                Thanks Wayne.

                Ok ran both queries and both gave me the: That action could not be completed. Please try again, and if this occurs again please contact the system administrator and tell them how you got this message.

                So I ran again and got : Invalid Page URL. If this is an error and the page should exist, please contact the system administrator and tell them how you got this message.

                Comment


                • #9
                  All these problems started after I switched from DB to Filesystem and it said all was good and finalized but all attachment links are broken and no new attachments can be uploaded.

                  Comment


                  • #10
                    Moving Attachments to the Filesystem would not cause these errors to suddenly start. That is a coincidence. Run the Queries from phpmyadmin and delete the cache to get the system operational again.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API

                    Comment


                    • #11
                      Ok, done. Site seems to be behaving better, it will now let me open blogs and articles but still cannot see attachments and still won't complete the install of 5.1.2. Still getting "
                      MySQL server has gone away" on step 18 of 18. Here's link to where some photos where before switch so Filesystem--> http://www.classicrv.net/forum/techn...-park-michigan

                      Comment


                      • #12
                        Wait, I was running the query on the Query tab in php myadmin and getting no response. When I run it on the SQL tab I get these --> "#1146 - Table 'classicrvforum.cacheevent' doesn't exist" and "#1146 - Table 'classicrvforum.cache' doesn't exist"
                        Last edited by Classicrv; Wed 3 Sep '14, 9:00am.

                        Comment


                        • #13
                          Update: Zachery found the path to the attachments was incorrect and repaired it so attachments are now visible and new attachments can be uploaded. Thank goodness!!

                          Problem still exists with upgrade to 5.1.2. Admincp shows that I am running 5.1.2 Patch Level 3 but install has never completed, always gives the "MySQL server has gone a way" on step 18.

                          Comment


                          • #14
                            How many styles do you have?

                            What is the wait_timeout for MySQL? (Admincp -> Maintenance -> Diagnostics -> System Variables -> MySQL Variables)
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud demonstration site.
                            vBulletin 5 API

                            Comment


                            • #15
                              Wait timeout is 60. Only using default style that I have modified a bit.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X