No announcement yet.

Please help I am so close.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help I am so close.

    Ok I have my site up and vBulletin installed. I get to my home forum page I can log in ect.. When I click on Main Forum i get this error. I can't figure it out Please if anyone can help I would really appreciate it.

    Warning: require_once() [[URL=""]function.require-once[/URL=""]]: open_basedir restriction in effect. File(/forum/upload/core/vb/vb.php) is not within the allowed path(s): (/home:/tmp:/usr) in /home/officeas/public_html/forum/includes/api/interface/collapsed.php on line 16

    Warning: require_once(/forum/upload/core/vb/vb.php) [[URL=""]function.require-once[/URL=""]]: failed to open stream: Operation not permitted in /home/officeas/public_html/forum/includes/api/interface/collapsed.php on line 16

    Fatal error: require_once() [[URL=""]function.require[/URL=""]]: Failed opening required '/forum/upload/core/vb/vb.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/officeas/public_html/forum/includes/api/interface/collapsed.php on line 16

  • #2
    You need to upload the contents of the upload folder not the upload folder itself.
    vBulletin skins and servcies:
    A to Z Talk:


    • #3
      Yes /upload/ shouldn't be on your server... Think of "upload" on your local machine as the "forum" folder on your server.

      ALSO you likely have a second issue:

      You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP -> Settings -> Options -> Server Settings and Optimization Options set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:


      Also the php.ini setting for 'upload_tmp_dir' may be empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777. You will also need to restart Apache after making this change.

      You will likely need to contact your host with those last instructions if you are on a shared host.


      • #4
        So these are the steps i did. I went to the upload folder copied all files with in and then pasted them into /home/officeas/public_html so not sure why its still looking for the upload folder or giving me that error. I tried to re copy the same files over again and produces the same error.


        • #5
          Ok. So been trying and trying. I finally got that error gone. now I have a new issue. so I goto my forum. I log in and when i click on Main forum I get this message
          "That action could not be completed. Please try again, and if this occurs again please contact the system administrator and tell them how you got this message."

          What am i missing now?


          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.