Announcement

Collapse
No announcement yet.

iOS App: Inputs don't work, no content is being shown

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    commented on 's reply
    Does the same issue happen in the actual app using Testflight on your device?

  • Isaac Way
    commented on 's reply
    Hi, I have changed the permissions for guests like you said and now forum content is showing up on my app, which is great. Thank you.

    However, the app's text inputs still just don't work (in the iPhone simulator at least). I am unable to create an account or login, it seems like as soon as I tap on a text input the app disables the text input with no feedback at all.

  • Wayne Luke
    replied
    Do you allow guests to view the "Home Page" channel under Channel Management → Channel Permissions? The "Can View Channel" permission must be set to Yes. This is required for the App to be able to connect to the API and operate properly.

    If you do not want guests to view your content, then set the "Can View Channel" permission to No for the guest user group on the Forum, Articles, Blogs, and Groups channels.

    Leave a comment:


  • iOS App: Inputs don't work, no content is being shown

    Hi,

    When I download my iOS and run it on the iPhone simulator, the application has two major problems:

    1. I cannot interact with any of the text inputs. It's impossible for me to enter a username/password or create account information. Buttons do work, though. It seems to be a problem with the text inputs only.

    2. No content is showing up. If I skip login and navigate to the "All" tab there are no posts even though our website forum has plenty of content. All of the tabs show the text "No Results"

    Not sure what's going on here.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X