Announcement

Collapse
No announcement yet.

Cannot complete iPhone app install. "resource envelope is obsolete"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot complete iPhone app install. "resource envelope is obsolete"

    I have tried to get the iPhone app submitted, but during the Re-Signing process it is rejected with an error message of "resource envelope is obsolete". I did some research and some people are claiming this is due to a recent iOS system updates. They are saying there are changes to the following that could cause a conflict with the Re-Signing for some apps. Can you please look into this and provide some instruction on how to get this app published? I am wondering if your app code will no longer work in the Re-Signing tool because of these iOS updates. Please correct me if I am misunderstanding this.
    Resource Envelopes Version 1 & 2

    (Code signatures containing version 1 or version 2 resource envelopes are also known as version 1 signatures or version 2 signatures, respectively)
    < OS X v10.9 (version 1)
    • Recorded only files in the Resources directory and ignored the rest.
    • Ignores symlinks.
    • If system is < 10.9 it ignores version 2 resource envelopes and use version 1 exclusively.
    • Uses documented signing feature (--resource-rules) to control which files in a bundle should be sealed by a code signature. (deprecated for 10.9+)
    OS X v10.9+ (version 2)
    • Records nested code (frameworks, dylibs, helper tools and apps, plug-ins, etc.)
    • Records substantially all files by default.
    • Records symbolic links.
    • Generates, by default, both version 2 and version 1 resource envelopes.
    • If a 10.9+ system sees a version 1 signature, it performs version 1 validation.
    • Always seals all files in a bundle; there is no need to specify this explicitly any more.
    • codesign on OS X 10.9+ and later does not show the version 1 resource envelope if a version 2 resource envelope is present, as only the version 2 resource envelope will be used.

  • #2
    You're on mavericks and not the dev preview, right?

    Comment


    • #3
      Yes, Mavericks

      Comment


      • #4
        Anyone have any input on this?

        Comment


        • #5
          I know we have an updated version (1.8) coming out soon. Do not have any additional info.

          Comment


          • #6
            Grrrr, I have the same problem.

            Comment


            • #7
              The app is compiled with XCODE 5. You should be using this version and not XCODE 6.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X