Announcement

Collapse
No announcement yet.

Mobile App showing invalid_api_signature

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobile App showing invalid_api_signature

    Hi,

    For the second month today right after I purchased the Mobile Suite I still couldn't resolve the error nor vBulletin Staff which they keep saying I have the wrong API version, yet I downloaded the package right from the Member's Area recently and the version has always shown 1.4.1, I've submitted a support ticket but for more than 2 weeks nothing has been fixed till now, I just keep repeating the steps, which are as follows:

    I've uninstalled both the MAPI from my Forums and the App from my Android and cleared the cache and data.

    Reinstalled the MAPI as it's showing 1.4.1 in Admin CP

    Generated a new API.

    Then updated the Mobile Publisher and after doing the whole process, I downloaded the package, extracted.

    Then uploaded again to Android Market (Called Google Play now) and waited for sometime.

    Then reinstalled the App on my mobile.

    Browsing the forums as mentioned earlier without login is working fine, but after login it's still showing the SAME error which is:

    invalid_api_signature




    Any ideas?

  • #2
    Are you using VBSEO?

    Comment


    • #3
      You cannot change the API Key at any time after the initial App creation. Uninstalling the MAPI plugin deletes the key and installing it again creates a new Key.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        johnarce: No.

        Wayne Luke: After uninstalling the MAPI plugin I generated a new API and then I updated the Mobile Publisher.

        Now after upgrading to the latest version of Mobile Suite I still have the same Error showing:

        Thank you for the Mobile Upgrade of the App to 1.2 and MAPI 1.4.2 which I have successfully downloaded and and then preformed all the steps mentioned earlier, which are:

        I've uninstalled both the MAPI from my Forums and the App from my Android and cleared the cache and data.

        Reinstalled the MAPI as it's showing 1.4.2 in Admin CP

        Generated a new API.

        Then updated the Mobile Publisher and after doing the whole process, I downloaded the package, extracted.

        Then uploaded again to Android Market (Called Google Play now) and waited for sometime.

        Then reinstalled the App on my mobile.

        Browsing the forums as mentioned earlier with login is working fine, but after login it's still showing the SAME error which is:

        invalid_api_signature

        Please advice.

        Comment


        • #5
          Originally posted by adhari_com View Post
          Please advice.
          Either the new API didn't completely take or addons are conflicting with the output. We recommend never changing the API key and you shouldn't uninstall the MAPI plugin to upgrade it.
          Last edited by Wayne Luke; Sat 24th Mar '12, 12:19pm.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud customization and demonstration site.
          vBulletin 5 Documentation - Updated every Friday. Report issues here.
          vBulletin 5 API - Full / Mobile
          I am not currently available for vB Messenger Chats.

          Comment


          • #6
            Originally posted by Wayne Luke View Post
            Either the new API didn't completely take or addons are conflicting with the output. We recommend never changing the API key and you shouldn't uninstall the MAPI plugin to upgrade it.

            We have this problem too.

            Have created a ticket that has been assigned to / replied by Trevor a couple of days ago.

            Have given him steps to reproduce the error today.

            Can reproduce on a stock installation (only changes are on the theme / style vars) with all plugins disabled using the Android app. Have not spent time on the iPhone app yet.

            I'm assuming this happens when fetching the notifications as the problem can be (more?) easily duplicated by opening the menu and attempting to navigate to the notifications screen.
            Last edited by shri; Sun 25th Mar '12, 7:36pm.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X