No announcement yet.

Trying to create App - Tells me wrong VB version

  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to create App - Tells me wrong VB version

    I am trying to create my app with for VB4.2.2

    This is the error I see: Your website is on an older version of vBulletin. We recommend you upgrade to the latest version of vBulletin. You need at least vB5 - 5.0.2, vB4 - 4.2.1, or vB3 - 3.8x plus the current Mobile API plug-in

  • #2
    Most likely means you don't have the API turned on or you have something blocking access to api.php like the vBSEO .htaccess file.

    To verify it is on go to Settings -> Options -> API and Mobile Application Settings and make sure access it enabled.

    Check your .htaccess files to makes sure nothing is blocking the call to api.php.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.


    • #3
      Interesting. API is def on, made sure of that before I did it. I'll check the .htaccess file. thank you

      Its not the htaccess file.. I removed it.
      Last edited by NxtGenCowboy; Sat 8 Feb '14, 6:09pm.


      • #4
        Is there anything else that could be causing this? I'd like to get my app out there for my users


        • #5
          Try this As of vBulletin 4.2.2 we’ve stopped suppressing notices and warnings. This is a change from all previous versions of the software.
          In some environments more notices/warnings show than in others. In order to address the issue you just need to add the following line to your config.php file
          define('SKIP_ALL_ERRORS', true);
          You can see additional information about this change here:


          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.