Announcement

Collapse
No announcement yet.

Buttons not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Wayne Luke View Post

    Can you recreate this issue with the vBulletin.com app? I have not experienced this with any 1.5 Apps that I have tried on my iPhone or iPad.

    If you can experience it, then you should create a JIRA so developers can look into it and confirm the issue. Until there is a JIRA created, there will be no progress. Developers do not visit the forum regularly.
    There is a JIRA entry since Oct. 1.
    The last time a developer did something in JIRA was Sept 25, so nobody has done anything since almost a month.

    Yes, we can "recreate" this issue with several iOS devices and several iOS versions at forums with vb3 installed. It does not happen with vb5 forums. Since we've tested it with the app version 1.3 and the most recent API also (it works without problems), we know the issue comes with the app version 1.5 and not with the API or our vb3 installation.

    If you can forward the issue to a developer (or at least inform them about it) I would be very happy. We have also sent you the .ipa file downloaded from your publisher in our support ticket to be tested by yourself.

    Means: There is no need to hint to a JIRA entry, because there already is one. There is no case in doubting that this issue exists, please test our file and you'll see it yourself. It is ridiculous that several people from vb answers to this thread the way you do and NOBODY seems to care about the issue itself.

    Comment


    • #17
      If we didn't care about the issue, we probably wouldn't post at all.

      Using an old Mobile 1.3 App with the new 1.4.5 API doesn't prove it is a Mobile 1.5 App issue. The Mobile 1.3 App won't use the newer 1.4.5 Beta 1 version of the API. Each folder in that API directory is a different version of the API. Those folder contain the changes needed to make specific versions of the App work. The App used will only access the API version it was developed with.

      In order to use Mobile Suite 1.5, you must have Mobile API for vBulletin 3.X 1.4.5 Beta 1 installed on your site. To download vBulletin 3.x API 1.4.5 Beta 1, you need to click the "More Download" options on the download screen and manually select the version from the dropdown. Otherwise you will download version 1.4.4.

      What is the ID of the JIRA so I can make sure your additional information above can be added. It is fairly critical so the developers actually know what they are working with. We can't really use your .ipa file. To test and develop with. We need apps built specifically for our test servers.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #18
        Originally posted by Wayne Luke View Post
        If we didn't care about the issue, we probably wouldn't post at all.

        Using an old Mobile 1.3 App with the new 1.4.5 API doesn't prove it is a Mobile 1.5 App issue. The Mobile 1.3 App won't use the newer 1.4.5 Beta 1 version of the API. Each folder in that API directory is a different version of the API. Those folder contain the changes needed to make specific versions of the App work. The App used will only access the API version it was developed with.

        In order to use Mobile Suite 1.5, you must have Mobile API for vBulletin 3.X 1.4.5 Beta 1 installed on your site. To download vBulletin 3.x API 1.4.5 Beta 1, you need to click the "More Download" options on the download screen and manually select the version from the dropdown. Otherwise you will download version 1.4.4.

        What is the ID of the JIRA so I can make sure your additional information above can be added. It is fairly critical so the developers actually know what they are working with. We can't really use your .ipa file. To test and develop with. We need apps built specifically for our test servers.
        Wayne, thank you for your comment. We have API version 1.4.5 Beta 1 running at our vb3 forum (if we hadn't we wouldn't even be able to finish the app creation in your mobile publisher).

        The ID of the JIRA is VBI-1022. The support ticket ID is 1222783. There you'll find the original .ipa app 1.5 file with our data, downloaded from your mobile publisher. If you sign the app with your developer "ad-hoc" key and install it at one of your devices you can see the error yourself (just to identify it). We cannot publish the broken app to the public, so it is not available through the Apple store.

        Again, none of your people took care about this problem since Oct. 1 beside of general instructional advice, which is not helping because we usually follow the instructions to the point and have quite capable people here.

        We even checked the API- (and also the server-) log but there is no entry if a non-working button in the app gets gets pressed. So we assume that the app simply does not forward the action of the pressed button to the API. If the app recognizes the pressed button at all.

        In addition version 1.5 of the Android app runs perfectly and was published Oct 1 with no customer complaints at all since then.
        Last edited by wmtech; Fri 25th Oct '13, 4:38pm.

        Comment


        • #19
          I have got this issue on my iOS app now. New app that has just been submitted and my users say the android app is better and works great. The ios one I have to run on an ipad running ios7 as I don't have an iPhone myself but it just acts as though there is blank space there and no buttons

          Comment


          • #20
            Yes. They have confirmed the error using my .ipa file some days ago.
            I was asked to redownload the app using the mobile publisher and try again. Did that and the error is still there.

            I am waiting since Oct. 1 for a solution to this problem.

            Comment


            • #21
              I have this app on 2 different forums and the users are now complaining about this same problem. I'm genuinely concerned that there is no sense of urgency to maintain these vb products anymore.

              Very disappointing.

              Comment


              • #22
                Same here on my 1.5 app. I called in and VB confirmed this on the phone with me that my app was doing this. I sent them the IPA file and they sent that over to the app developer. That was last week and have not heard anything. Last time I had to deal with the mobile developers it took a month.

                Here is the the link to the JIRA, please vote and comment.

                http://tracker.vbulletin.com/browse/VBI-1022

                Comment


                • #23
                  This is definitely an issue. Same problem here. . .
                  www.GigaThreads.com

                  Comment


                  • #24
                    Originally posted by Huskermax View Post
                    Last time I had to deal with the mobile developers it took a month.
                    It is already almost 2 months now.

                    Comment


                    • #25
                      I would suggest no one buy the mobile app until it's fixed.
                      www.GigaThreads.com

                      Comment


                      • #26
                        Today, more than 2 months after the initial support request, we received a manually compiled app file with working bottom buttons. It seems that the problem has been identified and may be solved soon for the mobile publisher.

                        Thank you, vBulletin!

                        Comment


                        • #27
                          Same issue here and many others as well.

                          Comment


                          • #28
                            we are having the same issue !
                            www.mysaltyreef.com

                            Comment


                            • #29
                              This has been one of the most upsetting bugs among my users (along with character encoding issues in the Android version making posts almost unreadable). Is there a new version where this is fixed coming up, like soon... ?

                              Comment


                              • #30
                                Originally posted by wmtech View Post
                                Today, more than 2 months after the initial support request, we received a manually compiled app file with working bottom buttons. It seems that the problem has been identified and may be solved soon for the mobile publisher.

                                Thank you, vBulletin!
                                I have not heard a thing. If this is happening to your app please vote and make a comment in the JIRA.

                                http://tracker.vbulletin.com/browse/VBI-1022

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X