Announcement

Collapse
No announcement yet.

Application rejected: "Invalid Signature"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Application rejected: "Invalid Signature"

    I struggled as it is with the arcane iPhone app process and its signatures, certificates, and keys.

    Now, I finally got the app signed following the instructions at https://www.vbulletin.com/forum/cont...gning-Your-App, got it uploaded, and got this email back almost immediately.

    "Dear Developer,

    We have discovered one or more issues with your recent binary submission for "Cyburbia". The following issues will need to be corrected in order for your application to proceed to review:

    Invalid Signature - Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target.

    Once you have corrected these issues, go to the app's version details page (found in the Manage Your Applications module of iTunes Connect) and click Ready to Submit Binary. Proceed through the submission process until the app's status is Waiting for Upload. You can then use Application Loader to upload the corrected binary.

    Regards,

    The iTunes Store Team"

    How can I resolve this? I have no idea how to "Clean All" in XCode, and I DID sign the app with a distribution certificate. However, the certificate I downloaded from the "Distribution Provisioning Profiles" page was named "Cyburbia_Profile.mobileprovision", not something like "1A90BDB-4372-4E.mobi" or "1FA54BD3-2602-4E7E-9D94-FC36D8E5328D.mobileprovision".
    Last edited by cyburbia; Sat 25th Jun '11, 5:42pm.
    Cyburbia Forums - a third place for urban planners
    http://www.cyburbia.org/forums

  • #2
    The 'Invalid Signature' issue is usually due to an add-on.

    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

    Admin CP -> Plugins & Products -> Manage Products -> Disable

    Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

    Admin CP -> Plugins & Products -> Plugin Manager

    You must do BOTH of those steps in order to disable all non vBulletin Modifications.

    Do you have the same problem? If so, fill out a support ticket at:

    https://members.vbulletin.com/member...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Okay ... it's staying on "Waiting for Review" this time, and no nastygram. Keeping my fingers crossed ...
      Cyburbia Forums - a third place for urban planners
      http://www.cyburbia.org/forums

      Comment


      • #4
        Originally posted by Steve Machol View Post
        The 'Invalid Signature' issue is usually due to an add-on.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all products (except vB Blog, vB CMS and Skimlinks if you have them.)

        Admin CP -> Plugins & Products -> Manage Products -> Disable

        Then manually uncheck all plugins that are not for 'vBulletin Blog' and vBulletin CMS' here:

        Admin CP -> Plugins & Products -> Plugin Manager

        You must do BOTH of those steps in order to disable all non vBulletin Modifications.

        Do you have the same problem? If so, fill out a support ticket at:

        https://members.vbulletin.com/member...ontactform.php

        Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
        If I do all of this, do I have to go through the whole "download the iPhone app, execute resign.sh, upload new .zip file and everything" again?? and if so, can i reenable all my addons on the forums once i upload the app to Apple and it gets approved??

        Comment


        • #5
          Originally posted by Saved0ne View Post
          If I do all of this, do I have to go through the whole "download the iPhone app, execute resign.sh, upload new .zip file and everything" again?? and if so, can i reenable all my addons on the forums once i upload the app to Apple and it gets approved??
          No, you do not have to redo the App. And yes, you can re-enable your add-ons once this is approved.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X