Announcement

Collapse
No announcement yet.

Unexpected server response

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rabban
    replied
    Originally posted by Zachery View Post
    Then, the issue is not vBulletin rabban
    Yes, you are right.
    I'm going report to VBSEO

    Leave a comment:


  • Zachery
    replied
    Then, the issue is not vBulletin rabban

    Leave a comment:


  • rabban
    replied
    Strange thing...

    My forum's threads works fine, but CMS and blogs returns this "Unexpected server response". Why this problem affect CMS and blogs only?

    With VBSEO disabled everything works!

    Leave a comment:


  • Vampyre
    replied
    Originally posted by cronjob78 View Post
    As advised by vBulletin support in the file includes/config.php place this line:

    ini_set(display_errors, 0);

    right under the opening <?php

    This allows me to login and browse and contribute to threads as normal.
    I also turned on all my plugins and add-ons and it still works. At the moment I have suhosin turned off but I suspect turning it back on might not affect the situation. I'll keep you posted and let me know if this works for the rest of you having the same issue.

    I'm not sure if this is a long term viable solution as now I'm assuming there can be no error messages. Let's see....
    This works for me on the interim as well.
    Let's see the long term effect this'll produce, I guess.

    Leave a comment:


  • Zachery
    replied
    Yes, keep removing functions from the eval black list until things start working.

    I would change the get_max_value_lenght to 2048, as well as your request / post limits as well. Also, I would advise the suhosin.memory_limit to double your normal memory, incase a script needs more.

    Leave a comment:


  • cronjob78
    replied
    Originally posted by Zachery View Post
    I would think can drop fopen, file_get_contents from suhosin, and maybe get it to work.
    just to be clear do you mean having this instead?

    suhosin.memory_limit = 32M
    suhosin.session.encrypt = Off
    suhosin.log.sapi = 511
    suhosin.get.max_value_length = 1024
    suhosin.executor.eval.blacklist = "exec,system,passthru,shell_exec,file_put_contents,tmpnam"


    This might make sense because I had intermittent problems with another CMS on the same domain not being able to upload images.

    Leave a comment:


  • Zachery
    replied
    I would think can drop fopen, file_get_contents from suhosin, and maybe get it to work.

    Leave a comment:


  • Sleepyboy2004
    replied
    Originally posted by cronjob78 View Post
    Turning off suhosin and inserting the line above into config.php seems to work for me.

    Over the weekend I asked the host to turn on suhosin again and I ended up with the same errors again.

    I found out how to tweak suhosin and got it working with suhosin still on. Here's how:

    vBulletin support asked me to insert the following lines into the bottom of includes/config.php

    suhosin.memory_limit = 32M
    suhosin.session.encrypt = Off
    suhosin.log.sapi = 511
    suhosin.get.max_value_length = 1024
    suhosin.executor.eval.blacklist = "exec,system,passthru,shell_exec,fopen,file_get_contents,file_put_contents,tmpnam"

    I got rid of the final line in bold and the app seems to work ok now with no error messages. If you have root access to your server you can put this in yourself (in Linux don't forget to use the command restart httpd after you save the file so the changes are picked up - don't know how this is done on windows servers) or else contact your host support who will do this for you.

    I don't have a mac or iphone so I can't tell whether the app works for iOS or not.
    I'll update if there are any changes to this situation I'll update below.
    After the 1st change you asked me to put in, things seem to be working better. I guess it took some time for changes to take effect.
    Debating on adding that code on there or leaving it alone as it still sits..... =/

    I managed to also load it on to my iPhone and just minor bugs are happening. Like the main one is; When I go to my profile, it kicks me out of the app. Same issue a lot of ppl have with the Facebook app. Seen it with a few friends.

    But for the most part, seems like things are back on the road

    Will update of any reported errors and/or problems.

    Leave a comment:


  • Zachery
    replied
    fopen is pretty noraml, i thought.

    Leave a comment:


  • cronjob78
    replied
    Turning off suhosin and inserting the line above into config.php seems to work for me.

    Over the weekend I asked the host to turn on suhosin again and I ended up with the same errors again.

    I found out how to tweak suhosin and got it working with suhosin still on. Here's how:

    vBulletin support asked me to insert the following lines into the bottom of includes/config.php

    suhosin.memory_limit = 32M
    suhosin.session.encrypt = Off
    suhosin.log.sapi = 511
    suhosin.get.max_value_length = 1024
    suhosin.executor.eval.blacklist = "exec,system,passthru,shell_exec,fopen,file_get_contents,file_put_contents,tmpnam"

    I got rid of the final line in bold and the app seems to work ok now with no error messages. If you have root access to your server you can put this in yourself (in Linux don't forget to use the command restart httpd after you save the file so the changes are picked up - don't know how this is done on windows servers) or else contact your host support who will do this for you.

    I don't have a mac or iphone so I can't tell whether the app works for iOS or not.
    I'll update if there are any changes to this situation I'll update below.

    Leave a comment:


  • Sleepyboy2004
    replied
    Quick thing that I wanted to add. How is it possible to have it work perfectly fine with Taptalk? Its almost the same thing, just really not my own app. But everything works with out a problem and dont have to disable anything.

    Leave a comment:


  • Sleepyboy2004
    replied
    Well tried that and still nothing. My sister was by and used her phone and these were some of the msgs that I would randomly get on and off.

    Connection error.
    Please try again

    error_postcount_too_low_thread


    Also all I could see was the new threads. When clicked on forums, didnt show anything. Tried as a guest, and as my account, and same thing either way.

    I think its going to take some work to get my site to work on this app. Still waiting for approval for apple. Hoping I dont have the same issues. But Who knows.

    Leave a comment:


  • cronjob78
    replied
    Voila!

    As advised by vBulletin support in the file includes/config.php place this line:

    ini_set(display_errors, 0);

    right under the opening <?php

    This allows me to login and browse and contribute to threads as normal.
    I also turned on all my plugins and add-ons and it still works. At the moment I have suhosin turned off but I suspect turning it back on might not affect the situation. I'll keep you posted and let me know if this works for the rest of you having the same issue.

    I'm not sure if this is a long term viable solution as now I'm assuming there can be no error messages. Let's see....

    Leave a comment:


  • Sleepyboy2004
    replied
    Sorry, just a bit frustrated. Hope to get to the bottom of with the help. Just got a lot going on and this just happens to be the cherry on top. Again, my apologies.

    Leave a comment:


  • cronjob78
    replied
    Sleepyboy, with respect, be patient, EPIC FAIL is an over-reaction.

    I'm sure it will be got to the bottom of. If its working for so many other people then there must be a minority of us who have certain settings that won't allow the app to function when we are logged in so its a matter of trying to find out what that issue is. As a programmer I know how painstakingly slow this process can be.

    Re: add-ons I've disabled all mine with every other suggestion from support so far and it doesn't seem they are the problem.

    Last night, I disabled suhosin in php.ini as that was suspected of being the issue but that unfortunately didn't yield any results either. As usual, just in case I disabled all add-ons just in case but no joy.

    I'm awaiting the next suggestion. Hopefully we'll be able to work out where the issue is soon. I'm really looking forward to using it and informing users about it. Aside from the current "unexpected response from server" error it looks and feels great so fingers crossed.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X