Announcement

Collapse
No announcement yet.

Unexpected server response

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by Zachery View Post
    I would think can drop fopen, file_get_contents from suhosin, and maybe get it to work.
    just to be clear do you mean having this instead?

    suhosin.memory_limit = 32M
    suhosin.session.encrypt = Off
    suhosin.log.sapi = 511
    suhosin.get.max_value_length = 1024
    suhosin.executor.eval.blacklist = "exec,system,passthru,shell_exec,file_put_contents,tmpnam"


    This might make sense because I had intermittent problems with another CMS on the same domain not being able to upload images.

    Comment


    • #47
      Yes, keep removing functions from the eval black list until things start working.

      I would change the get_max_value_lenght to 2048, as well as your request / post limits as well. Also, I would advise the suhosin.memory_limit to double your normal memory, incase a script needs more.

      Comment


      • #48
        Originally posted by cronjob78 View Post
        As advised by vBulletin support in the file includes/config.php place this line:

        ini_set(display_errors, 0);

        right under the opening <?php

        This allows me to login and browse and contribute to threads as normal.
        I also turned on all my plugins and add-ons and it still works. At the moment I have suhosin turned off but I suspect turning it back on might not affect the situation. I'll keep you posted and let me know if this works for the rest of you having the same issue.

        I'm not sure if this is a long term viable solution as now I'm assuming there can be no error messages. Let's see....
        This works for me on the interim as well.
        Let's see the long term effect this'll produce, I guess.

        Comment


        • #49
          Strange thing...

          My forum's threads works fine, but CMS and blogs returns this "Unexpected server response". Why this problem affect CMS and blogs only?

          With VBSEO disabled everything works!
          Crossroad of the worlds

          Comment


          • #50
            Then, the issue is not vBulletin rabban

            Comment


            • #51
              Originally posted by Zachery View Post
              Then, the issue is not vBulletin rabban
              Yes, you are right.
              I'm going report to VBSEO
              Crossroad of the worlds

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X