Announcement

Collapse
No announcement yet.

ImpEx from ikB to vbb4.x user post html chars not converting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trevor Hannant
    replied
    Sorry, was travelling most of the weekend so couldn't reply...

    I've actually just posted a fix in your other thread. I'll leave that there for anyone else with the issue

    Leave a comment:


  • Mike1969
    replied
    I figured it out (come on guys, im not a sql administrator in any way, but this was easy... id have thought someone could have posted this alot quicker than it took me to figure it all out... but i digress...)

    If anyone has this problem, just run these sql queries on your new db after vbb is all setup and old db imported:

    UPDATE [table] SET [column] = REPLACE([column], '& #39;', '''');
    UPDATE [table] SET [column] = REPLACE([column], '& #33', '!');
    UPDATE [table] SET [column] = REPLACE([column],'& #036', '$');
    UPDATE [table] SET [column] = REPLACE([column], '& #163', '');
    UPDATE [table] SET [column] = REPLACE([column],'& #128', '€');
    UPDATE [table] SET [column] = REPLACE([column], '& #192', '\\');

    (spaces added after "&" for proper display here)

    Phew! FIXED!
    Last edited by Mike1969; Sun 18th Nov '12, 2:32pm.

    Leave a comment:


  • snakes1100
    replied
    Not thru impex there isnt, you might be able to convert them afterward, if i do recall its been posted on here before, a script, i also seen a few posts where vb support has also fixed/converted it.

    Leave a comment:


  • Mike1969
    replied
    Thanks for the tip, snakes. Unfortunately, I have the website on a hosted server and I dont have access to the global MySQL configs. There must be a way to run a SQL script that would open/update/save each use post in that table. It would seem if we can do this one-by-one in the forum, SQL would be able to do it in one step.

    Thoughts?

    Leave a comment:


  • snakes1100
    replied
    MySQL also needs its charset, set it the same on all 4, noted in red, set the correct char in my.cnf & restart it.

    Code:
    mysql> status;
    --------------
    mysql  Ver 14.14 Distrib 5.1.62, for pc-linux-gnu (x86_64) using readline 5.1
    
    Connection id:          29007460
    Current database:
    Current user:           root@localhost
    SSL:                    Not in use
    Current pager:          /usr/bin/less
    Using outfile:          ''
    Using delimiter:        ;
    Server version:         5.1.62-log Gentoo Linux mysql-5.1.62-r1
    Protocol version:       10
    Connection:             Localhost via UNIX socket
    Server characterset:    latin1
    Db     characterset:    latin1
    Client characterset:    latin1
    Conn.  characterset:    latin1
    

    Leave a comment:


  • ImpEx from ikB to vbb4.x user post html chars not converting

    After successfully importing my ikB 3.12a db into vBB 4, Ive found the user posts do not display non-alpha chars correctly.
    Example: the imported forums posts display "& #33;" instead of "!"

    ikB and its db is UTF8, and after noticing this issue, i went back and reset it to Latin1_swedish along with the new vBB db and reimported with ImpEx. Still the same issue.


    If I edit a post in vBB and just save (without actually changing anything) the post then displays correctly.

    What to do? This is the last issue it seems, before I can go ahead and work on aesthetics before the official ikB>vBB upgrade/launch.

    Any help or ideas would be greatly appreciated!

Related Topics

Collapse

Working...
X