Announcement

Collapse
No announcement yet.

Help please with Impex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help please with Impex

    Please can some one help me here, I have been sitting here for nearly 8 hours trying everything, I have to the stage where I have started pulling my hair out.

    I want to import my phpBB3 database to vB4.2.0. My phpbb3 files are on a different server to my vB4 forum.

    I have downloaded the Impex and installed it on my vB4 server and I can see the import tab in my ACP. When I click on the import tab it then asks me for my customer number, when I enter this I get this message

    Warning:
    Cannot modify header information headers already sent by (output started a /home/tradio/public_html/tff/impex/ImpExConfig.php:1) in /home/tradio/public_html/tff/impex/impex_auth.php on line 22


    Can any help me please...

    Mark

  • #3
    Here how the top of it looks Trevor, is it ok.
    <?php
    if (!defined('IDIR')) { die; }

    #################################################################### |;
    # vBulletin - Licence Number VBCE7DCC25
    # ---------------------------------------------------------------- # |;
    # Copyright �2000�2012 vBulletin Solutions Inc. All Rights Reserved. |;
    # This file may not be redistributed in whole or significant part. # |;
    # ---------------- VBULLETIN IS NOT FREE SOFTWARE ---------------- # |;
    # http://www.vbulletin.com | http://www.vbulletin.com/license.html # |;
    #################################################################### |;
    # The following settings allow ImpEx to connect to the vBulletin 3
    # database into which you will be importing data.

    ####
    #
    # TARGET - The target is the vBulletin database (where the data is going to)
    #
    ####

    - - - Updated - - -

    Right I have made a bit more progress and I can now get to the import module stage.

    001 - seemed to work ok
    002 - skipped as there are now users that I want merging with vb4
    003 - seemed to work ok
    004 - seemed to work ok
    005 - brings up the following error message, any ideas what I need to do

    ImpEx Database error
    mysql error: Invalid SQL: SELECT forum_id, forum_name, forum_desc FROM forums WHERE parent_id = 0
    mysql error: Table 'traditio_fisherman.forums' doesn't exist
    mysql error number: 1146
    Date: Friday 28th 2012f September 2012 05:47:41 PM
    Database: traditio_fisherman
    MySQL error: Table 'traditio_fisherman.forums' doesn't exist

    Comment


    • #4
      It looks like the forum table is missing from the db. If I were you I would re-start the whole process from the start again.

      Comment


      • #5
        Ok I will start from the beginning, from a new Impres install.

        Why are things so complicated, I feel like continuing my phpBB3 forum and forgetting vb4, I have spent literally days on this.

        I now get these errors (both the same) on my VB4 forum but it still seems to work ok.

        Warning: number_format() expects parameter 1 to be double, string given in [path]/includes/functions.php on line 844

        Warning: number_format() expects parameter 1 to be double, string given in [path]/includes/functions.php on line 844

        Comment


        • #6
          That often happens when an incorrect date of birth value is present in the database. Double check your user table and make sure all dates of birth have a 4 digit year for them
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - Highlight the correct navigation tab when you are on a custom page
          - "Quick Route" Interface...
          - Allow to use custom icons for individual forums

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X