Announcement

Collapse
No announcement yet.

Wordpress

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wordpress

    I'm getting an error that I can't seem to figure out. I have Wordpress 2.8 and from what I've read, the imported "should" still work since there aren't usually structural changes between major releases.
    Anyway - everything runs fine until I go to import the posts. It's like the script is losing my table prefixes. My table prefixes are wp_blog_ and they are setup correctly in the config file. I'm able to run all the beginning steps without problems and it's correctly connecting to the database utilizing my table prefixes.
    But when I go to import the posts, I get this error.

    Code:
    ImpEx Database error
    
    mysql error: Invalid SQL: SELECT posts.* 
                        FROM wp_posts AS posts
                        LEFT JOIN wp_term_relationships AS term_relationships ON (term_relationships.object_id = posts.ID)
                        WHERE term_relationships.term_taxonomy_id IN (0,1,4,21,32,54,56,118,188,207,220,260,346,365,53,278)
    
    
    mysql error: Table 'blogdb.wp_posts' doesn't exist
    
    
    mysql error number: 1146
    
    
    Date: Friday 24th 2012f August 2012 12:30:54 AM
    Database: blogdb
    MySQL error: Table 'blogdb.wp_posts' doesn't exist
    * I changed the db name when I pasted this here simply because I wasn't sure if that would have been a security issue.

    Anyway - it seems from the error that it's lost the correct prefix.

  • #2
    No insight at all?

    Comment


    • #3
      Originally posted by femsawyer View Post
      No insight at all?
      Sorry, I've never tried importing from worddpress but..

      does blogdb.wp_post table exist?
      -- Web Developer for hire
      ---Online Marketing Tools and Articles

      Comment


      • #4
        No. The database is blogdb. But my table prefixes are wp_blog_ - which is all configured within the config file. All of the steps of importing works (check/update database, associate users, import blog users, import blog category) until I reach the step to import the blog. That's when I get the error. It's like all of the beginning steps are accessing the database correctly with the correct table prefixes, but once it goes to import the blog, for some reason, it's not using the correct table prefix.

        Comment


        • #6
          what a shame! I was hoping to move to the vbulletin blog, but I'm not willing to give up all my previous blog posts to do it. I'm hoping maybe that someone who has had this problem and has overcome it can share some insight. I can hope right?

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X