Announcement

Collapse
No announcement yet.

Vanilla to VB4 Import Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vanilla to VB4 Import Problem

    Hi
    Im finally getting round to using the VBulletin software,
    Ive got 3 sites:

    Site A - Our purchased forums (vanilla), tring to import to Site B atm
    Site B - a test forum site before it is finally moved to the new home site C
    Site C - Final home of the VBulletin forums
    VBulliten is installed and running on Site B & C

    Ive got the sqldump #.sql from Vanilla located on Site B,
    And have created the #.db fine

    When im using ImpEx to import it into the existing vbulletin.db it connects fine to both .db,

    Check and update database - works fine,
    Associate Users - Is mainly a fresh forum, has 8 test users including me and my mate.
    Import usergroup - Imports sucessfully 7 groups
    Import user - this is where it goes wrong, "Invalid , skipping. Failed on : usergroupid"

    Im getting the 3310 uses in the userlist fail.

    This is the output from Check and update database: im using $impexconfig['source']['tableprefix'] = 'GDN_'; and $impexconfig['target']['tableprefix'] = '';

    Altering tables
    ImpEx will now Alter the tables in the vB database to include import id numbers. This is needed during the import process for maintaining references between the tables during an import. If you have large tables (i.e. lots of posts) this can take some time. They will also be left after the import if you need to link back to the original vB userid.
    moderator - importmoderatorid Completed
    usergroup - importusergroupid Completed
    ranks - importrankid Completed
    poll - importpollid Completed
    forum - importforumid Completed
    forum - importcategoryid Completed
    user - importuserid Completed
    style - importstyleid Completed
    thread - importthreadid Completed
    post - importthreadid Completed
    thread - importforumid Completed
    smilie - importsmilieid Completed
    pmtext - importpmid Completed
    avatar - importavatarid Completed
    customavatar - importcustomavatarid Completed
    customprofilepic - importcustomprofilepicid Completed
    post - importpostid Completed
    attachment - importattachmentid Completed
    pm - importpmid Completed
    usernote - importusernoteid Completed
    phrase - importphraseid Completed
    subscription - importsubscriptionid Completed
    subscriptionlog - importsubscriptionlogid Completed
    filedata - importfiledataid Completed

    Testing source against : vanilla ::1.1.4


    Valid found tables :

    GDN_Category found.
    GDN_Comment found.
    GDN_Discussion found.
    GDN_Role found.
    GDN_User found.

    Possibly custom tables or incorrect prefix :

    GDN_Attachment NOT found.
    GDN_CategoryBlock NOT found.
    GDN_CategoryRoleBlock NOT found.
    GDN_DiscussionUserWhisperFrom NOT found.
    GDN_DiscussionUserWhisperTo NOT found.
    GDN_IpHistory NOT found.
    GDN_Poll NOT found.
    GDN_PollBlock NOT found.
    GDN_PollData NOT found.
    GDN_PollRoleBlock NOT found.
    GDN_Style NOT found.
    GDN_UserBookmark NOT found.
    GDN_UserDiscussionWatch NOT found.
    GDN_UserRoleHistory NOT found.
    GDN_UserSearch NOT found.

    Most of which I dont think are needed anyway,

    Any ideas on where to go from here?
    Last edited by B4.; Fri 20th Jul '12, 7:21pm.

  • #2
    I am having this same issue. It's actually Vanilla 2.0.x Does Impex support this newer version of Vanilla?

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X