Announcement

Collapse
No announcement yet.

Importing from several databases? How can i remove the import tags on profiles?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Importing from several databases? How can i remove the import tags on profiles?

    Okay, so I was looking through the documentation and I noticed that it will delete any user with an import tag on the user. Where is this tag and how can I delete it so that I can import more from another database?

    Yes, it sounds odd that I would have multiple databases but it's a long complicated story....

    Anyway, I doubt it's the "imported_" part of the username that it adds to the imported users. I did find some kind of user note that was on a user that I had combined, is that part of it?

    I still have another database that need to be combined so that I can restore my site to a complete database and not have gaps in information.

    Could anyone advise on this situation?

  • #2
    anyone with knowledge of this, searches have not turned up anything....

    - - - Updated - - -

    okay, so I found something that helps to a degree but the problem is that when I try to clean the database I get an error///

    I'm referring to this text here:
    To remove the import id's use the clean database found at the top of the ImpEx page, as show in the attached images.
    from post 2 of https://www.vbulletin.com/forum/show...mporting-HOWTO

    how can I fix this error problem?

    ImpEx Database error

    mysql error: cannot use database vbulletin_forum


    mysql error: Access denied for user 'myusernamefor DB user'@'%' to database 'vbulletin_forum'


    mysql error number: 1044


    Date: Friday 20th 2012f July 2012 12:53:07 PM
    Database: vbulletin_forum
    MySQL error: Access denied for user 'myusername*****'@'%' to database 'vbulletin_forum'
    - - - Updated - - -

    O, I see the thread was moved, thanks for that. I didn't even notice this forum. Any help would be really appreciated.

    I was doing some reading on the error that come up but the problem is that the databases are all "localhost" so what do I need to do here?

    This is a whole new kind of issue for me. I've never had many issues with my sites before.

    Do I need to enable queries in the main forum's config file or something?

    Comment


    • #3
      The "access denied for user..." error means you have an incorrect username, password, or database name in your config.php file. I assume it means your imprex config file since your forum wouldn't work at all if it was the forum config file.

      Comment


      • #4
        Originally posted by BirdOPrey5 View Post
        The "access denied for user..." error means you have an incorrect username, password, or database name in your config.php file. I assume it means your imprex config file since your forum wouldn't work at all if it was the forum config file.
        But the import went fine without any issues. Why would the import pull all the data from the old database, use the passwords I gave it but then not work right on this last step? It's a little misleading because the import went fine, it's this last step that is getting all messed up.

        Comment


        • #5
          Did you install vb in the same db as your source forum?

          Comment


          • #6
            Originally posted by borbole View Post
            Did you install vb in the same db as your source forum?
            no they are 2 separate databases with 2 completely different names.

            I spent hours last night trying to find if I have a phpmyadmin system on my server and it seems I don't. I also tried to fine a way to access the database through some kind of mysql admin tool to do some queries but it seems I'm not sure how to get to that either.

            I'm on a virtual dedicated server where I host several websites.

            - - - Updated - - -

            I did have to re-upload the older database so I used my root access to place it into the database I made from my plesk panel in the same domain as the destination database. I gave the 2nd database a unique name. ran the mysql command while logged in as root and it uploaded in a few seconds without issue. Then I went in and modified the impex config file and uploaded the whole set up files via ftp into the right folders and went through all the steps but now it wont let me do that one last step.

            - - - Updated - - -

            when I go to the import page now, all i get is the option to do the clean up:


            and it states:
            Using includes/config.php for target config.


            Comment


            • #7
              Try to redo the conversion once again. But this time install vb in the same db as that of your source forum.

              Comment


              • #8
                Originally posted by borbole View Post
                Try to redo the conversion once again. But this time install vb in the same db as that of your source forum.
                How would I do that seeing as I have 2 separate databases that hold years of information that are completely separate. I'm combining an old database that has 2 years of information to the current one that has the last 5-6 years of data....

                Are you saying to use impex to import them to a whole new database?


                There has to be a way to get the system to allow me to finish the import that I have currently done.

                Comment


                • #9
                  You need to raed over the multi import docs: https://www.vbulletin.com/docs/html/impex_multi_import

                  Comment


                  • #10
                    well, I tried changing up the user name and password and changes all the config files to match and it's still giving me this damn 1044 error.

                    There has to be something that I'm missing here, if anyone has any other suggestions I'd really like to hear them...

                    - - - Updated - - -

                    Originally posted by Zachery View Post
                    You need to raed over the multi import docs: https://www.vbulletin.com/docs/html/impex_multi_import
                    The problem is that I haven't even gotten to finish the first import.

                    I need to finish this first import inorder to continue to the second.

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X