Announcement

Collapse
No announcement yet.

Help with multi import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with multi import

    Hi again.
    Back with a new question regarding multi import, and yes, I have read the guide and i dont really understand since i'm new to both VB and Impex

    The first step i'm stuck on is this
    When you have done an import and are completely finished and wish to do another import you will have to set all these import id's to 0.

    How and where do i menage that? Everything is done on the test forum, but i want to do it right at the first try.

  • #2
    Bottom line of the page:

    To remove the import id's use the clean database found at the top of the ImpEx page
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      EDIT: Sorry. Someone has screwed up somewhere since the e107 files was older then the rest of the impex files.

      First question after an succesfull import.
      Is there an easier way to move all imported users to correct usergroup or do i have to move them manually one by one? As it is not they belong to group "imported_users"
      Last edited by jebediah; Thu 17 May '12, 4:39am.

      Comment


      • #4
        It's possible that those files haven't been updated for some time especially seeing as it's a Tier 3 (unsupported) system:

        https://www.vbulletin.com/docs/html/impex_tiers
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          Ok, but in the end it worked
          But the question remains.
          How can i move all the new users to correct group, if even possible. Or do i have to move them one by one?
          Also, all special characters like "åäö" get replaced by a questionmark.

          Comment


          • #6
            What group do you want them to be in? If the 'Registered Users' group, then simply delete the group they're in and they'll be moved there automatically. If another, which one?

            What do you see if you check the 'post' table in the database? Do the characters there have question marks or are they as they should be?
            Vote for:

            - *Admin Settable Paid Subscription Reminder Timeframe*
            -
            *PM - Add ability to reply to originator only*
            - Add Admin ability to auto-subscribe users to specific channel(s)
            - "Quick Route" Interface...

            Comment


            • #7
              Originally posted by Trevor Hannant View Post
              What group do you want them to be in? If the 'Registered Users' group, then simply delete the group they're in and they'll be moved there automatically. If another, which one?
              Yes it is the "Registered Users" group, so i'll give it a try. Thanks.


              Originally posted by Trevor Hannant View Post
              What do you see if you check the 'post' table in the database? Do the characters there have question marks or are they as they should be?
              I've looked in the database file and the special characters are there, so it has to be something wrong with Impex.
              Last edited by jebediah; Thu 17 May '12, 7:36am.

              Comment


              • #8
                Originally posted by jebediah View Post
                I've looked in the database file and the special characters are there, so it has to be something wrong with Impex.
                If you looked in the posts table and the special characters are there than ImpEx is working correctly. It is the character encoding of your site that is incorrect. Make sure to install your language pack and update the encoding appropriately.

                Languages & Phrases -> Language Manager. Edit the languages with the problem to have the proper encoding for that language.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  It's not wrong with any settings in VB. We made a import for not long ago and that worked just fine.
                  UTF-8 is set for encoding which is right for Swedish.
                  I dont really understand what you are meaning with "posts table", but if i open up the database file i can se all the threads correct.

                  Also, all the imported users with special characters get that wierd looking question mark.

                  Comment


                  • #10
                    The database "file" isn't anything that vBulletin uses directly. You need to look inside the database itself using a tool like phpMyAdmin and look at the contents of the post table.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      EDIT: I have to investigate it more closely and come back later.
                      Last edited by jebediah; Thu 17 May '12, 12:54pm.

                      Comment


                      • #12
                        So, back again with some more info
                        All the special characters look great in phpmyadmin in the database we are trying to import.
                        I've also changed the collation to utf8_swedish_ci "same as the current forum has today"
                        Languages & Phrases -> Language Manager has UTF-8

                        But special characters are still showing up as wierd questionmarks. Have i missed something?

                        EDIT: Finally got it. Had to change
                        define('use_utf8_encode', true);
                        define('use_utf8_decode', true)
                        in ImpExConfig.php

                        - - - Updated - - -

                        A final question.
                        some sub-forums couldn't be imported
                        Got category and DID NOT imported to the mysql database

                        No explanation what so ever and the sub-forums looks the same as all the others. Any sugestion?
                        Last edited by jebediah; Thu 24 May '12, 12:33pm.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X