Announcement

Collapse
No announcement yet.

ERROR: importing phpBB 3.0.9 database into vBulletin 4.1.10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ERROR: importing phpBB 3.0.9 database into vBulletin 4.1.10

    This is my first time ever importing one database to another, so I tried to read the instructions very carefully. Both my phpBB database (Blog) and vBulletin database (forum) are on the same Yahoo server, accessed by phpMyAdmin. My Yahoo account uses Mysql Version: 5.1.55 and phpMyAdmin 2.11.9.6. I have my main forum installed in root/forum with another installation in root to transfer from root to /forum. This is how I configured my ImpExConfig.php file.

    PHP Code:

    ####

    $impexconfig['target']['server']        = 'localhost';
    $impexconfig['target']['user']            = 'myhostUN';
    $impexconfig['target']['password']        = 'myhostPW';
    $impexconfig['target']['database']        = 'forum';
    $impexconfig['target']['tableprefix']    = '';

    # If the system that is being imported from uses a database,
    # enter the details for it here and set 'sourceexists' to true.
    # If the source data is NOT stored in a database, set 'sourceexists' to false

    $impexconfig['sourceexists']            = true;

    ####
    #
    # SOURCE - The source is the old forum database (where the  data is coming from)
    #
    ####

    # mysql / mssql
    $impexconfig['source']['databasetype']    = 'mysql';  // mysql OR mssql
    $impexconfig['source']['server']        = 'localhost';
    $impexconfig['source']['user']            = 'myhostUN';
    $impexconfig['source']['password']        = 'myhostPW';
    $impexconfig['source']['database']        = 'Blog';
    $impexconfig['source']['tableprefix']   = 'phpbb2_';

    #### 
    I also deleted all of the folders out of the upload > impex > system folder, except for phpBB3 which is what the manual told me to do. In following these instructions, after I uploaded, I also put a copy of the cpnav_impex.xml file in both the root/includes/xml folder as well as in the root/forum/includes/xml folder. After doing this, I went to my ACP and lo! I saw the added Import feature, but when I actually clicked on it I got this:



    And then I tried clicking on the Impex index.php file, and it asked for my Customer Number, which I gave it, and it said Success! ... and then flipped-over and gave me this message:



    I have re-traced my steps and feel I did everything perfectly ... but I did not get anything but a blank screen. Maybe one of my files failed to load in the ftp transfer? Should I not have deleted all those folders out of the System Folder?

    Any expert help would sure be appreciated!

    Jack
    Attached Files
    Last edited by MacroPhotoPro; Thu 23 Feb '12, 5:46pm.
    Website | Facebook | Flickr Photostream

  • #2
    What Yahoo hosting package are you using? Is it Small Business Server by any chance? Are the connection details in the ImpexConfig.php file for your vB database exactly the same as in your includes/config.php file?
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Yes it is the Yahooo Small Business Server, Trevor.

      And the only difference in my config files would be the includes/config file has $config['MasterServer']['servername'] = 'mysql',

      while the ImpexConfig file has $impexconfig['target']['server'] = 'localhost';

      But I have switched them back and forth and still get the same error message

      Any ideas where I zigged when I should have zagged?
      Website | Facebook | Flickr Photostream

      Comment


      • #4
        The settings in the ImpexConfig.php file should match those in the config.php file. Are you able to access the rest of AdminCP and your site OK with the correct settings in config.php?
        Vote for:

        - *Admin Settable Paid Subscription Reminder Timeframe*
        -
        *PM - Add ability to reply to originator only*
        - Add Admin ability to auto-subscribe users to specific channel(s)
        - "Quick Route" Interface...

        Comment


        • #5
          Yes, my overall VBulletin experience is perfect. The forum, cms, blog, AdminCP all work perfectly.

          I can even see the Import feature in my ACP after loading Impex ... but when I click the "Import" link, the first picture I posted (404 Not Found) is what I get.

          I also loaded cpnav_impex.xml file into my includes/xml folder.

          Jack
          Website | Facebook | Flickr Photostream

          Comment


          • #6
            PS: You also mentioned Yahoo Small Business server by name ... is there a known compatibility problem between Impex and the Yahoo Small Business server?
            Website | Facebook | Flickr Photostream

            Comment


            • #7
              Please fill out a support ticket at:

              http://members.vbulletin.com/members...ontactform.php

              Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
              Vote for:

              - *Admin Settable Paid Subscription Reminder Timeframe*
              -
              *PM - Add ability to reply to originator only*
              - Add Admin ability to auto-subscribe users to specific channel(s)
              - "Quick Route" Interface...

              Comment


              • #8
                Done.

                Thanks for trying.
                Website | Facebook | Flickr Photostream

                Comment


                • #9
                  Problem Solved!

                  A big thanks to Trevor for his immediate, polite (and very patient with a newby!) help on this

                  Cheers,

                  Jack
                  Website | Facebook | Flickr Photostream

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X