Announcement

Collapse
No announcement yet.

Attachment import from IPB 3.4.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment import from IPB 3.4.3

    Hi,

    today I imported a forum that I acquired into my own forum using Impex 1.104. The old forum runs on IPB 3.4.3 and my site is based on vBulletin 4.2.1.
    Every step worked properly except importing attachments. It always turned out error messages like:
    "Source file not found :: monthly_05_2010post-1-127366130333.jpg"

    It was definitely the correct absolute path! I even tried relative paths and many alternatives. I've spend half a day, read forums and so on, but I couldn't figure it out.

    To explain the current file names:
    I changed the names in both database and FTP (with prior folder name in it and removed commas, because I thought, that could be the issue). I also renamed the column "attach_location" to "attach_file", because otherwise Impex would look for file names that do not exist.

    So as I said: The file names in the error messages are now exactly the same as in the directory!


    Please help!

    Thanks,
    Jakob
    Last edited by jakobility; Thu 27th Jun '13, 3:35pm.

  • #2
    Can you track the errors via the log file on the server, either via apache error log or the servers messages located in /var/log?

    You can also try to turn on display_errors in php.in and restart it, you would need to see the full path its looking for the image to be in, which may be a easier route than getting vb to fix impex.
    Gentoo Geek

    Comment


    • #3
      Unfortunately I couldn't find any information in the log/error files indicating the path impex is looking for.

      Comment


      • #4
        Can you post the actual paths involved? Change your user account name to just xxx or something if you want.

        Comment


        • #5
          The path to my old attachments is:
          /is/htdocs/wp106xxxxx_XXXXXXXXXX/www/tabxxxxxxx/attachments

          Comment


          • #6
            I'd really appreciate it if anyone gave advice on this problem

            Comment


            • #7
              Do you have VB4 Suite or purchased a license in the last 30 days? If so you can open a support ticket.

              Otherwise I keep re-reading the first post. I'm not sure why you would re-name the column 'attach_location' - was this suggested somewhere else?

              Comment


              • #8
                Originally posted by Joe D. View Post
                I'm not sure why you would re-name the column 'attach_location' - was this suggested somewhere else?
                No, but I changed it because I thought that Impex is using the information of 'attach_file' while the correct file name was in 'attach_location'.

                Anyway, I've just reset everything and did a clean import. It worked fine without needing to change anything in the database
                I don't know why it didn't work at the first try. Doesn't matter.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X