Announcement

Collapse
No announcement yet.

phpBB3 to vBulletin failing on posts import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • phpBB3 to vBulletin failing on posts import

    Let me preface this by saying that I have imported over 100 phpBB/SMF/Other boards to vBulletin and have never had a single issue...ever. This time, though, I'm about to pull my hair out.

    Client has a phpBB database about 1.5GB in size. I installed a fresh VB installation and started the import of everything. Before this, I removed ALL of the memory limits and script timeouts in PHP. All of the imports went fine. 75,000 users, 270,000 threads. When I went to the posts importer, I expected everything to work, but it didn't.

    The importer successfully copies about 29 posts and then continues loading infinitely, never copying another post. If I load up impex again, it imports those same 29 and then sits there. Thinking this was a problem with the next post in the phpBB table, I deleted it entirely and went through the whole process again....same thing. So I installed VB3 and attempted an import into that, thinking it might help...same thing.

    At this point, I've spent well over 5 hours on this with no resolution, and I'm just about to give up. I have no idea why it's doing this. No errors either in the log or the the impexerror table. No PHP memory limit. No max execution time....

    Please help.

  • #2
    What is the 30th post?

    Comment


    • #3
      Originally posted by Zachery View Post
      What is the 30th post?
      Just regular old text. And like I said above - I deleted the 30th post thinking that might be it. It's not. I deleted the first 1000 posts from the phpBB table and same thing.

      What I have discovered is that it doesn't freeze completely. It simply does 29 posts and then proceeds VERY slowly. At the rate of about 1 every few minutes. This is the same behavior on 3 different servers. The current one I'm doing the process on has 48GB of ram. I just don't know what the problem could be. It doesn't make sense.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X