Announcement

Collapse
No announcement yet.

Impex SQL Errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impex SQL Errors

    Hi, just bought and downloaded 4.2.1, created a separate folder on my webhost to try my hand at importing my phpbb3 forum. I've been running this forum for 5 years but my php skills are very limited. I've edited the impexconfig file to the best of my knowledge but when trying to import my database into the new database I created, (by doing import>import in the admincp) I get this error. the table vb_vbfields only exists in the target database, not the source one, I have no idea what the error means



    mpEx Database error

    mysql error: Invalid SQL: CREATE TABLE `vb_vbfields` (
    `fieldname` varchar(50) NOT NULL default '',
    `tablename` varchar(20) NOT NULL default '',
    `vbmandatory` enum('Y','N','A') NOT NULL default 'N',
    `defaultvalue` varchar(200) default '!##NULL##!',
    `dictionary` mediumtext NOT NULL,
    `product` varchar(25) default ''
    )


    mysql error: Table 'vb_vbfields' already exists

    mysql error number: 1050

    Date: Tuesday 11th 2013f June 2013 06:51:16 PM
    Database: philm_vBull
    MySQL error: Table 'vb_vbfields' already exists

  • #2
    There shouldn't be a vbfields table in vBulletin unless you've already run Impex and haven't cleaned up afterwards. If you use phpMyAdmin and delete that table then re-run Impex, you should be OK.
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - Highlight the correct navigation tab when you are on a custom page
    - "Quick Route" Interface...
    - Allow to use custom icons for individual forums

    Comment


    • #3
      Thanks, to tell the complete story, I ran impex a few times because I got syntax errors several times, very limited knowledge here of how I need to edit the config file. I thought I had fixed the syntax errors when I got that message, now that I deleted all the data inside the vbfields table, I reran impex and got the same syntax error as before, which is this

      ImpEx Database error

      mysql error: Invalid SQL: CREATE TABLE vb_impexerror (
      errorid bigint(20) unsigned NOT NULL auto_increment,
      errortype varchar(10) NOT NULL default '',
      classnumber varchar(3) NOT NULL default '',
      importid bigint(20) NOT NULL default 0,
      error varchar(250) default 'NULL',
      remedy varchar(250) default 'NULL',
      PRIMARY KEY (errorid)
      ) TYPE=MyISAM

      mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9

      mysql error number: 1064

      Date: Tuesday 11th 2013f June 2013 08:13:40 PM
      Database: philm_vBull
      MySQL error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9


      I don't have a manual so can't check the syntax, I'm not sure I'd know what to check, can someone have a quick look at what I'm doing wrong?

      Comment


      • #4
        This is what my config file looks like, am I doing something wrong?


        $impexconfig['target']['server'] = 'localhost';
        $impexconfig['target']['user'] = 'philm';
        $impexconfig['target']['password'] = 'mypassword';
        $impexconfig['target']['database'] = '_vBull';
        $impexconfig['target']['tableprefix'] = 'vb';

        # If the system that is being imported from uses a database,
        # enter the details for it here and set 'sourceexists' to true.
        # If the source data is NOT stored in a database, set 'sourceexists' to false

        $impexconfig['sourceexists'] = true;

        ####
        #
        # SOURCE - The source is the old forum database (where the data is coming from)
        #
        ####

        # mysql / mssql
        $impexconfig['source']['databasetype'] = 'mysql'; // mysql OR mssql
        $impexconfig['source']['server'] = 'localhost';
        $impexconfig['source']['user'] = 'philm';
        $impexconfig['source']['password'] = 'otherpassword';
        $impexconfig['source']['database'] = '_phpb1';
        $impexconfig['source']['tableprefix'] = 'phpbb';

        #### etc....

        If I look at my PHPMyAdmin screen, it tells me my username is philm and that my databases are called _phpb1 and _vBull, all the talbes under _phpb1 start with the prefix phpbb_ and the ones in _vBull start with the prefix vb_ ovbiously I changed the password in this post, is my syntax ok? is it possible it throws the error because of a wrong password?

        Comment


        • #5
          If you edit the file impex/index.php and change TYPE=MyISAM to ENGINE=MyISAM located at or near line 271, this should resolve this for you.
          Vote for:

          - *Admin Settable Paid Subscription Reminder Timeframe*
          -
          *PM - Add ability to reply to originator only*
          - Add Admin ability to auto-subscribe users to specific channel(s)
          - Highlight the correct navigation tab when you are on a custom page
          - "Quick Route" Interface...
          - Allow to use custom icons for individual forums

          Comment


          • #6
            Thanks for that, that solved it. I finally got to the import screen, awesome!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X