Announcement

Collapse
No announcement yet.

Internal Server Error while importing posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Internal Server Error while importing posts

    Hello,

    I always got an 500 Server Error when I try to import the posts from the IPBoard. (About 70.000 posts). In the VBulletin Database all posts are imported.Then the reload an the error.

    Is there any solution?

    I also increased the php values but it didnt help.

    EDIT: I deleted posts with more than 50k chars. The largest post has about 37k chars

  • #2
    Is there any help? I wasnt able to solve the problem until now

    Comment


    • #3
      You need to look at your server logs to find out what the error is. Either your httpd or php error logs should contain the error. Without that, there really isn't much to go on. Internal Server Error is vague and applied to many different issues.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        These 2 errors are in the log file:

        Code:
        [Wed Mar 13 19:07:10 2013] [warn] [client my ip] mod_fcgid: read data timeout in 45 seconds, referer: http://www.mydomain.de/impex/index.php
        
        	[Wed Mar 13 19:07:10 2013] [error] [client my ip] Premature end of script headers: index.php, referer: http://www.mydomain.de/impex/index.php




        I already deleted:



        pp.notes (Line 703, 000.php) because otherwise I got another error and the import doesnt start
        Also I changed TYPE=MyISAM to ENGINE=MyISAM (line 271, index.php )

        Comment


        • #5
          In the Web I found this:
          http://rickchristie.com/blog/2011/no...timeout-error/

          So I tried to reproduce the error with the following php script:
          PHP Code:
          <?php

              
          echo 'go<br />';

              
          $sleep 120;

              echo 
          $sleep ' sleep<br />';

              
          sleep($sleep);

              echo 
          'finished<br />';

              
          ?>
          Same problem So I need to increase theese values. But the next problem ist that I donīt know how to do this.

          (Ubuntu + Plesk 11)

          Comment


          • #6
            In the Web I found this:
            http://rickchristie.com/blog/2011/no...timeout-error/

            So I tried to reproduce the error with the following php script:
            PHP Code:
            <?php

                
            echo 'go<br />';

                
            $sleep 120;

                echo 
            $sleep ' sleep<br />';

                
            sleep($sleep);

                echo 
            'finished<br />';

                
            ?>
            Same problem So I need to increase theese values. But the next problem ist that I donīt know how to do this.

            (Ubuntu + Plesk 11)

            Comment


            • #7
              In the Web I found this:
              http://rickchristie.com/blog/2011/no...timeout-error/

              So I tried to reproduce the error with the following php script:
              Code:
              <?php
              
              	echo 'go<br />';
              
              
              	$sleep = 120;
              
              
              	echo $sleep . ' sleep<br />';
              
              
              	sleep($sleep);
              
              
              	echo 'finished<br />';
              
              
              	?>
              Same problem So I need to increase theese values. But the next problem ist that I donīt know how to do this.

              (Ubuntu + Plesk 11)

              Comment


              • #8
                In the Web I found this:
                http://rickchristie.com/blog/2011/no...timeout-error/

                So I tried to reproduce the error with the following php script:
                Code:
                <?php
                
                	echo 'go<br />';
                
                
                	$sleep = 120;
                
                
                	echo $sleep . ' sleep<br />';
                
                
                	sleep($sleep);
                
                
                	echo 'finished<br />';
                
                
                	?>
                Same problem So I need to increase theese values. But the next problem ist that I dont know how to do this.

                (Ubuntu + Plesk 11)

                Comment


                • #9
                  If you're on a shared host you may need to contact your host to increase the timeout value.

                  Comment


                  • #10
                    I increased the value now but now I get "Bad Gateway" there isnt any information in the log. Do you know anything to solve the problem?

                    Comment


                    • #11
                      Do you have any type of caching enabled?

                      502 Errors Explained: http://www.checkupdown.com/status/E502.html

                      Comment


                      • #12
                        Well now I "rebuilded" the cache of everything and the posts appeared. But I am not able to import the other stuff like pmīs or polls because when i try to open /impex/index.php the error appears. Is there any way to imports PMs whithout import Users?

                        Comment


                        • #13
                          No, PMs need to be associated with users otherwise how will the software know whose PM is whose...
                          Vote for:

                          - *Admin Settable Paid Subscription Reminder Timeframe*
                          -
                          *PM - Add ability to reply to originator only*
                          - Add Admin ability to auto-subscribe users to specific channel(s)
                          - Highlight the correct navigation tab when you are on a custom page
                          - "Quick Route" Interface...
                          - Allow to use custom icons for individual forums

                          Comment


                          • #14
                            The users are already imported. The error appears while importing the posts. When i try to open /impex/index.php i couldnt import the pms because the error appears again. I have to delete the session and posts ... via help.php

                            Comment

                            Related Topics

                            Collapse

                            Working...
                            X