Announcement

Collapse
No announcement yet.

Impex Script using outdated Syntax?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impex Script using outdated Syntax?

    I wanted to run this locally on my machine to see if it works, and if it does, just upload my new vb db and do a mysql dp import. I decided just to use WampServer so everything installs and whatever. Anyways, I had a really curious error:

    Code:
    ImpEx Database error
    
    mysql error: Invalid SQL: CREATE TABLE impexerror (
                            errorid bigint(20) unsigned NOT NULL auto_increment,
                            errortype varchar(10) NOT NULL default '',
                            classnumber varchar(3) NOT NULL default '',
                            importid bigint(20) NOT NULL default 0,
                            error varchar(250) default 'NULL',
                            remedy varchar(250) default 'NULL',
                            PRIMARY KEY (errorid)
                        ) TYPE=MyISAM
    
    mysql error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9
    
    mysql error number: 1064
    This happened as soon as I was I clicked Import > Import. I could go to the help.php file, and I tried doing the reset option (I forgot which one it was, but something abotu deleting sessions and the imports, just to see if that was it) and it all went okay.

    I guess what the problem is, to make things short, is that the syntax using the TYPE setting, which was, previously, a warning given, to now a flat out error. I'm not sure how many times this is used, but is there a way around this, or do I have to install an old version of MySQL or what?

    Here is the bug ticket for this kind of error:
    http://bugs.mysql.com/bug.php?id=17501

    I have MySQL version 5.5.8 running through wampserver2.

  • #2
    Check the bug tracker in vBulletin for Impex, and I would suggest reporting the bug so it can get addressed.

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X